OHC Wiring...(I searched) - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-18-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
OHC Wiring...(I searched)

I installed my OHC and everything appeared to be working correctly. I didn't have enough quick splices, one short, so I waited to hook up the map/dome lights. I figure no big deal and ran and got some today.

I hooked up the light Green/Orange to Green/Orange on the dome light connection and Black/Red to Black/Blue at the dome light connection...well the dome light stays on constantly...and the map lights don't work.

I pulled all the electrical tape off and realized my wires didn't match up with the car domain instructions

Here is what I have (Off to the right is what I believe is correct)

1. Black - GND

2A. Yellow/Gray - I hooked this up behind the radio - console electronics power
2B. Blue/Red - I hooked this up behind the HVAC - console display dimmer input

3A. Green/Orange
3B. Black/REd (Where does this wire go because it should be Black/Blue)
* 3A and 3B should go to the existing dome light wiring - Right now the wires aren't connected *

4A. Lt. Blue/White - Temp Sensor
4A. Lt. Blue/Yellow - Temp Sensor

5. Gray/Black - VSS
Later,

Last edited by Hillyard; 06-19-2008 at 08:38 AM.
Reply With Quote
  #2  
Old 06-18-2008
oldman_d's Avatar
Member
 
Join Date: Mar 2008
Location: WA
Posts: 116
If I remember right group two hooks up behind the radio. Blue with red stripe should be behind the radio, and that controls the dimmer function of your console. And I believe that the yellow with grey stripe should be behind the radio also.
Reply With Quote
  #3  
Old 06-19-2008
08XLT4x4's Avatar
Member
iTrader: (7)
 
Join Date: Mar 2008
Location: bomba shack
Posts: 3,257
what year truck? it seems every year ford decided to change some wire colors so if something isnt working that might be the problem.
Reply With Quote
  #4  
Old 06-19-2008
Shaklakan's Avatar
Member
 
Join Date: Jan 2008
Location: La Habra CA
Posts: 1,100
ditto on what dave said. Im still in the process of getting my lazy *** to wire the dome lights. Lol im still having trouble getting the damn console to work. I think its just a bad console so i probably need a new one.
Reply With Quote
  #5  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
If you look at the wires I have only one wire that's different, BK RD vs BK BL. That is throwing off the wiring not my truck's wiring. The truck wiring is fine and the console works but the dome/map lights don't. The temp sensor is dead on so that's a plus...lol

I know for a fact the temp gauge wires, VSS, and GND are correct. It is the other 4 I'm worried about


A while back I asked rwenzing for some help with installing a second fog lamp button. He said the Blue black wire might be Red Black (I think) in Explorers. I'm not sure if that would apply to here or not...

I'm stumped...I should have checked to see if the dimmer worked when i had it wired up...

Last edited by Hillyard; 06-19-2008 at 08:48 AM.
Reply With Quote
  #6  
Old 06-19-2008
Step Over the Edge's Avatar
Member
 
Join Date: Dec 2007
Location: Albuquerque, NM
Posts: 324
Stupid question, but I gotta ask... Does it stay on when you close the truck door? Or is the dimmer switch clicked up to have the light on?
Reply With Quote
  #7  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
Quote:
Originally Posted by Step Over the Edge View Post
Stupid question, but I gotta ask... Does it stay on when you close the truck door? Or is the dimmer switch clicked up to have the light on?
It's not stupid because that's the first thing I checked. I thought the dome light might need to be hooked up in order for it to turn off but it worked fine. I know it is the pigtail wiring.
Reply With Quote
  #8  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
Should 2B and 3B should be switched? I did some researching about hooking up a second switch using an explorer bezel. Well today I remember Rwenzing said this "The RD/BK is also dash illumination on some Fords so tying it to the LB/RD is fine."

MINE
2A. Yellow/Gray - I hooked this up behind the radio - console electronics power
2B. Blue/Red - I hooked this up behind the HVAC - console display dimmer input

3A. Green/Orange
3B. Black/REd (Where does this wire go because it should be Black/Blue)
* 3A and 3B should go to the existing dome light wiring - Right now the wires aren't connected *

CarDomain
2A. Yellow/Gray (YE/GY) - console electronics power
2B. Blue/Red (BL/RD) - console display dimmer input - Mine will be Black Red

3A. Green/Orange(GN/OR) - Map light power
3B. Black/Blue(BK/BL) - Dome light power

No I just confused myself...hmmm I wonder where the Light Blue/ Red Wire should go then...
Reply With Quote
  #9  
Old 06-19-2008
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Do you have the diagram for wiring up the 2nd switch? I need to do that as well.
Reply With Quote
  #10  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
Quote:
Originally Posted by 04blackedge View Post
Do you have the diagram for wiring up the 2nd switch? I need to do that as well.
That was a piece of cake...running the wires in a factory manner was the hardest part.

Here is the link.
https://www.ranger-forums.com/forum2...ad.php?t=29897

Piece of advice. There should be a hole on the underneath of your truck behind the inside of the mud flap bracket. It should have a piece of foam insulating it (I can get a picture). You can snake the wires up behind the kick panel and then place your relay and wiring in there. I placed the relay behind the kick panel because there is a little cubby hole in there for it. On the Passenger side the factory places one on that side so you can use it as a reference but it makes the perfect spot for an extra relay in the cab.

I ran my OHC Wire temp sensor wires and the extra switch wiring at the same time. It was quite the project but it looks really good now that it is done and all my wiring is seperate from everything else.

Last edited by Hillyard; 06-19-2008 at 09:51 AM. Reason: fubar
Reply With Quote
  #11  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018


Picture is of my female pigtail.

2A. Gray/Yellow - I hooked this up behind the radio - console electronics power
2B. Red/BK - I hooked this up behind the HVAC - console display dimmer input

3A. Green/Orange
3B. Black/Blue
* 3A and 3B should go to the existing dome light wiring - Right now the wires aren't connected *

When connected the OHC dome light stays on LIKE it's connected to the battery with no switch.

Gray/Black - VSS wire on ECC

Last edited by Hillyard; 06-19-2008 at 01:39 PM.
Reply With Quote
  #12  
Old 06-19-2008
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Oh the wiring isn't a problem, I just needed the diagram.
Reply With Quote
  #13  
Old 06-19-2008
Rooks's Avatar
Member
iTrader: (7)
 
Join Date: Sep 2006
Location: Minneapolis, MN
Posts: 1,867
Griggs's write up is about the best I've seen. Pages 3 and 4 of his cardomain.

http://www.cardomain.com/ride/296394/3
http://www.cardomain.com/ride/296394/4

EDIT: My bad... didn't read the OP fully. Sorry about that.

Last edited by Rooks; 06-19-2008 at 01:40 PM.
Reply With Quote
  #14  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
Quote:
Originally Posted by SniperX103 View Post
Griggs's write up is about the best I've seen. Pages 3 and 4 of his cardomain.

http://www.cardomain.com/ride/296394/3
http://www.cardomain.com/ride/296394/4
I used that but please read the original post...
Reply With Quote
  #15  
Old 06-19-2008
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by Hillyard View Post


Picture is of my female pigtail.
console .............. Ranger

red/black............. light blue/red - radio or HVAC panel
black.................. chassis ground
gray/yellow.......... yellow/black - radio
gray/black........... gray/black at GEM connector
black/light blue..... black/light blue at dome
light green/orange. light green/orange at dome
blue/white........... temp sensor
blue/yellow.......... temp sensor
Reply With Quote
  #16  
Old 06-19-2008
Rangerguy's Avatar
Member
 
Join Date: Feb 2008
Location: California
Posts: 1,120
I have the black/red wire too on my OHC, everything is hooked up except that wire. I tried to tap into the dimmer with it but it doesnt work. Works great otherwise.
Reply With Quote
  #17  
Old 06-19-2008
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by Rangerguy View Post
I have the black/red wire too on my OHC, everything is hooked up except that wire. I tried to tap into the dimmer with it but it doesnt work. Works great otherwise.
The dimming feature may not work properly depending which year console is being used in which year Ranger. I had to install an Explorer dimmer and change some harness wiring in mine to get it to work. I have a 2003 Ranger with the later green display console.
Reply With Quote
  #18  
Old 06-19-2008
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Zach - If you have it wired as in my post above and you're still having problems with the dome and maps, you may have the wires crossed above the dome light assembly. Were those 2 plastic terminals removed from the roof at any time?
Reply With Quote
  #19  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
Quote:
Originally Posted by rwenzing View Post

red/black............. light blue/red - radio or HVAC panel
black.................. chassis ground
gray/yellow.......... yellow/black - radio
gray/black........... gray/black at GEM connector
black/light blue..... black/light blue at dome
light green/orange. light green/orange at dome
blue/white........... temp sensor
blue/yellow.......... temp sensor
That's the way I hooked it up...hmmm. Thanks for double checking everything for me.

Quote:
Originally Posted by rwenzing View Post
Zach - If you have it wired as in my post above and you're still having problems with the dome and maps, you may have the wires crossed above the dome light assembly. Were those 2 plastic terminals removed from the roof at any time?
Not to my knowledge. I bought the truck used but the previous owner only put 25k miles on it in 7 years and everything looks immaculant and in factory condition. I can try switching them.

I thought about trying to switch them but I was tired and figured I would ask first. It would make sense because the map lights switch on and off so you can tell them what to do as opposed to the dome lights that only come alive when a door is opened.
Reply With Quote
  #20  
Old 06-19-2008
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
It is possible that the dome light assembly is just turned around backwards? In other words, do all three screws line up with the 3 screw holes?
Reply With Quote
  #21  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
Quote:
Originally Posted by rwenzing View Post
It is possible that the dome light assembly is just turned around backwards? In other words, do all three screws line up with the 3 screw holes?
Yes the 3 screws line up. I have the rectangle dome light without any map lights.

Since I didn't have the quick connect I did try to mount a Ranger dome light with map lights but it didn't work it just stayed on also. I never removed the wires when I was messing with it and the original dome light works perfectly. I figured I would try to get this solved first.
Reply With Quote
  #22  
Old 06-19-2008
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Do the console lights work properly when the factory dome is not installed?
Reply With Quote
  #23  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
Quote:
Originally Posted by rwenzing View Post
Do the console lights work properly when the factory dome is not installed?
No. The OHC light just stays on. In fact as soon as I tapped the GR/OR wire it stayed on. I then tapped the BK/BL wire but it stayed on.
Reply With Quote
  #24  
Old 06-19-2008
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Did the pigtail and the console come from the same Explorer?
Reply With Quote
  #25  
Old 06-19-2008
Hillyard's Avatar
Member
Thread Starter
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
Quote:
Originally Posted by rwenzing View Post
Did the pigtail and the console come from the same Explorer?
I bought it from the junkyard but I wasn't allowed to pull it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
searched, found nothing. Big Vibration in front end UNCCRang49 Drivetrain Tech 18 12-03-2014 04:17 PM
OHC Mod.... yes i have searched flyboyjay69 Interior Semi-Tech 1 02-05-2012 08:17 PM
OHC question, yes i searched. ranger_1999 Interior Semi-Tech 3 06-28-2010 05:34 PM
i searched and couldnt find it-coil overs Urandaman Suspension Tech 2 03-15-2007 01:14 AM
I have searched the ends of the world.... BigRed911 Suspension Tech 9 03-06-2007 11:29 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:00 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.