P0171 and P0174? Why am I getting these codes? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-29-2010
Member
Thread Starter
 
Join Date: Apr 2010
Location: Colton,CA
Posts: 3
P0171 and P0174? Why am I getting these codes?

I have a 2004 Ranger Edge, 3.0L V6. Whenever I'm getting on the freeway the check engine light comes on and when i check the codes its always P0171 and P0174. After looking these up I found that the are Lean Bank 1 and Lean Bank 2. Whats causing this? Do I need to clean something? Do I need to replace something? Help please.
Reply With Quote
  #2  
Old 04-29-2010
Ace's Avatar
Ace Ace is offline
Member
iTrader: (4)
 
Join Date: Aug 2007
Location: Central, Illinois
Posts: 3,448
we have a thread on here somewhere on how to fix it, but right now im far to tired to actually look for it.
Reply With Quote
  #3  
Old 04-29-2010
fourliter dan's Avatar
Member
 
Join Date: Dec 2007
Location: Lebanon, OR
Posts: 2,229
its a rubber hose that runs into the intake that cracks and alows unmetered air into the intake causing it to run lean on the a/f mixture.... its an easy fix and i recomend cleanig the throtle body and maf sencors and idle air valve.

the line runs down the pasanger side of the intake and does a 90degree turn and dumps in right after the intake. ide post a pic but photo bucket is down for maint. ill have it up soon
Reply With Quote
  #4  
Old 04-29-2010
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
ben (jeweler) has a write up on this


edit:

here this is what you need

https://www.ranger-forums.com/f15/fi...1-po174-87334/
Reply With Quote
  #5  
Old 05-13-2010
Member
Thread Starter
 
Join Date: Apr 2010
Location: Colton,CA
Posts: 3
Solved the problem by cleaning the MAF. Sprayed it down with some EPS electro-contact cleaner and lightly brushed off the sensors witha pipe cleaner. Worked like a charm. Truck passed its first smog with flying colors! Thanks for all your responses!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
p0171 and p0174 codes moonliteshawn 4.0L OHV & SOHC V6 Tech 5 08-12-2012 03:57 PM
P0171, P0174, P2195, P92197 codes 04RangerDude 4.0L OHV & SOHC V6 Tech 6 05-16-2012 06:24 PM
throwing codes p0171 p0174 mikey7o2 4.0L OHV & SOHC V6 Tech 12 03-12-2012 02:26 AM
P0171/P0174 codes - found cracked rubber elbow COOLANT PROBLEM?? Bird76Mojo 4.0L OHV & SOHC V6 Tech 7 08-26-2011 04:50 PM
p0171 and p0174 rdy4mud General Technical & Electrical 13 02-20-2008 12:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:16 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.