PATS flashing, Ranger won't start.. help! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-10-2011
Member
Thread Starter
 
Join Date: Jan 2011
Location: kelowna, BC
Posts: 11
Icon4 PATS flashing, Ranger won't start.. help!

Hi Guys,

2004 Ranger FX4 Level II 4.0 auto

I've done some searching through the threads and wondering if there is any way to overcome this issue without towing my truck to the nearest Ford dealer to have the ECU flashed and new keys programmed.

Truck has been starting with no issues for the 4 months I've owned it, I go out to start it tonight and when I turn the key to start it I get nothing at all, except the PATS light flashing like a beast. All the electrical items work fine, battery is good, no clicking, everything is the exact same as it was this morning except for the flashing PATS light. I have 2 original Ford keys and now neither one of them will start the truck. I tried disconnecting the battery for a few minutes but that didn't help.

Any way of getting past this without spending lots of cash at the dealer?

Thanks in advance for your thoughts!

TheBishop
Reply With Quote
  #2  
Old 03-10-2011
WowMike2001's Avatar
Member
 
Join Date: Oct 2007
Location: Stevenson, WA
Posts: 2,583
Havfe you tried disconnecting the battery, flicking the lights on to drain what remains of any electrical, then repluggign it back in? May have some sort of bug in it that can be flushed out be a battery drain :-)
Reply With Quote
  #3  
Old 03-11-2011
Member
Thread Starter
 
Join Date: Jan 2011
Location: kelowna, BC
Posts: 11
Tried it... no dice. Thanks for the thought though. Looks like the dealer is going to get a few of my hard-earned pennies after all.

I'll let you know what the damage ends up being!

TheBishop
Reply With Quote
  #4  
Old 04-24-2011
Member
 
Join Date: Apr 2011
Location: De Soto, MO
Posts: 8
I have the same problem with my 2001. Was wondering what the damage was.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
bypass PATS for Remote Start ThatGuy85 General Technical & Electrical 1 10-31-2013 10:41 PM
Incorrect jump start. Truck won't start now. Pilot General Technical & Electrical 3 10-27-2013 08:07 AM
Very weird! Won't start, won't shut off, flashing exterior lights fletcher969 2.9L & 3.0L V6 Tech 4 01-14-2013 06:26 PM
Wiring PATS into non-pats vehicle dayton525 General Technical & Electrical 3 12-07-2011 10:00 PM
Won't start, dome light dies when trying to start. Jerkstore General Technical & Electrical 4 10-02-2011 10:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:56 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.