Pleaaaassse help!!! A question for the best!! 2.9 89 ranger - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-21-2013
Member
Thread Starter
 
Join Date: Aug 2013
Location: Elora ontario
Posts: 7
Pleaaaassse help!!! A question for the best!! 2.9 89 ranger

I have an 89 xlt 4x4 auto with the 2.9. I am getting fairly frustrated. The issue is the engine starts idles great. Well mayb not idles great but good. When you floor this thing in neutral the rpms go up very slow as if the timing is off. When in the road and from dead stop and floor it a pedal bike will get to 50kph faster. This thing will not go over 70kph to the floor.
I've checked codes nothing major
I have a parts truck here's what I've tried
I checked timing its exactly 10' no flutter
The inside if distributor is clean pip and cap and rotor all look fine.
All grounds cleaned in engine back and pass kick panel
I tried another coil
I tried another tps
I tried another map
I tried the relays and with that ill mention the fuel pump will not turn on unless jumped and I've tried inertia and new relay but still only works jumped
I installed new fuel pump and pressure is 35&40
Plugs look fine

Has anyone had this issue or any ideas? Could faulty pip or ignition module cause this kind of problem? I'm at wits end here please help:)

Oh I also poped distributor cap watched rotor and rotated crank back and fourth the chain has very minimal play

Is it possible to drop the distributor in one tooth wrong and the timing light still lines up on the crank 10' mark with no flutter?? Or can I assume its right being steady 10' now?
And I also checked exhaust and fuel filter both clean
Reply With Quote
  #2  
Old 08-21-2013
Member
Thread Starter
 
Join Date: Aug 2013
Location: Elora ontario
Posts: 7
K thanks anyhow found issue

No replies thanks guys. Anyhow after a couple hours testing this and that turns out the trucks only running on the 3 upper injectors. The wiring fir the lower 3 has pulses so I'm assuming the lower 3 are all corroded or seized from sitting since 2011. Ill keep the post going for results
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
dumb question, whats the best 4x4 ranger to own? hoursetraitor General Ford Ranger Discussion 3 05-23-2011 08:28 AM
Which tune for best mileage: torque or performance (SCT question) n3elz 2.9L & 3.0L V6 Tech 25 01-23-2007 08:46 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.