Problem??? Maybe??? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-02-2008
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
Problem??? Maybe???

So i was driving my 1998 Ranger 4x4 3.0l 5sp back to St. Louis Sunday afternoon and when i was on the highway i noticed something. When i would let off the gas my truck would start pulling right and then when i would push back on the gas it would pull back to the left. It wasn't pulling real bad but was noticeable. I didn't know if anybody else had experienced this or if they had heard of this or what might be wrong. Thanks for any help.
Reply With Quote
  #2  
Old 12-02-2008
Member
 
Join Date: Sep 2007
Location: LANSING, MI
Posts: 339
alignment, the road, wind, tires, bad tie rods, bad shocks or springs, to much weight on either side of the truck. its called torque steer. check your tire pressure and ur front suspension.
Reply With Quote
  #3  
Old 12-02-2008
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
I just replaced the shocks this summer i will check to back sure they are still tight. I dont have springs. It was doing it the whole time on the trip so i doubt it was just the road. How do you tell if the tie rods are bad? will they be lose? thanks
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help me diagnose my problem (maybe transmission) Lammchop1993 4.0L OHV & SOHC V6 Tech 4 02-23-2015 10:49 AM
Fuel Pump? Maybe? Maybe not? grrrrrrr mikewurtz General Technical & Electrical 3 03-01-2012 08:46 PM
01 XLT 4X4 Maybe/Maybe not! shagdue Drivetrain Tech 7 12-11-2011 10:49 AM
think i may have dangerous problem - knocking / loud tick maybe from left brake ccarr1025 General Technical & Electrical 3 03-29-2010 08:30 AM
Subwoofer Problem, maybe major. Tyrant924 Audio & Video Tech 18 02-18-2008 04:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:04 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.