seatbelt light on after deck replacement - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-07-2012
brc0703's Avatar
Member
Thread Starter
 
Join Date: Sep 2012
Location: Ca
Posts: 111
seatbelt light on after deck replacement

so i replaced my stock stereo with a sony deck and now my seatbelt light stays on (the light of the guy in a seat with a big letter D)..it flashes and turns off sometimes (even with seat belt off) but it will turn back on shortly after.. i didnt cut the harness i used a connector and taped up all the loose wires not being used.. not sure what i did to affect the seat belt sensor..

also i taped over the holes to the buzzer in the dash cuz its loud enough and very annoying.. is there a way to make it not beep when the keys are in the ignition?
Reply With Quote
  #2  
Old 10-08-2012
drppdyllwrngr's Avatar
Member
iTrader: (4)
 
Join Date: Sep 2007
Location: wilmington, nc
Posts: 2,096
sounds like the airbag light, not the seat belt light. post a picture just to make sure. if it is the airbag light, it will flash a series of times, short pause, flash another series of times, long pause, then repeat a few times before staying on. this is your code. IE, flash 2 times, pause, flash 7 times, long pause, repeat is a code 2-7, or the passenger switch light burnt out.
Reply With Quote
  #3  
Old 10-08-2012
brc0703's Avatar
Member
Thread Starter
 
Join Date: Sep 2012
Location: Ca
Posts: 111
oh that makes sense.. i did pop off the pasenger side airbag cover on the dash.. just a big empty hole with a wire connecting to the cover... i disconnected it and it didnt want to reconnect so i left it only half way pressed in.. the end looked like just a cap for the electical so i didnt think it was a big deal.. thanks ill reconnect it and see if it fixes it
Reply With Quote
  #4  
Old 10-08-2012
drppdyllwrngr's Avatar
Member
iTrader: (4)
 
Join Date: Sep 2007
Location: wilmington, nc
Posts: 2,096
yeah, that is probably a dummy sensor. still completes the circuit.
Reply With Quote
  #5  
Old 10-09-2012
brc0703's Avatar
Member
Thread Starter
 
Join Date: Sep 2012
Location: Ca
Posts: 111
yeah that was it.. reconnected it and light went away.. i looked for a pic of the light but cant find one so ill have to take a pic tomorrow and post it.. it looks like a guy wearing a seatbelt and a big D i assumed was for driver lol.. i was clickin the crap out of my seatbelt buckle and bouncing in the seat.. wasnt sure if it had a seat sensor to acknowledge there was a person in the seat or not..what a dork lol..
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Airbag light and no seatbelt signal jbird17 General Technical & Electrical 1 05-24-2015 04:37 AM
Seatbelt Pretensioners On Explorer Seats? Fazda Interior Semi-Tech 3 04-14-2006 12:50 AM
Seatbelt chime rimrocks General Technical & Electrical 15 02-27-2006 10:11 PM
Riddle me this... Seatbelt pretensioner plug/airbag light.. rngprerunner General Technical & Electrical 20 02-20-2006 10:01 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:13 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.