speedo problems - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-08-2011
Member
Thread Starter
 
Join Date: Apr 2011
Location: mulkeytown ill
Posts: 2
speedo problems

2000 ranger 2 wheel drive having problems with speedo quiting while driving. know the ABS light came on dash, I have changed sensor on the rearend but it seemed to make it worse. When the speedo stops kicks off OD and seems to make transmission be out of gear. NEED HELP!!!
Reply With Quote
  #2  
Old 04-08-2011
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,835
The rear axle sensor is the most common cause of speedometer/ABS problems in 1998~2000 Rangers.

However, there is another problem area in 2000~2003 Rangers that could be worth checking. Here's what I would do:

Disconnect and isolate the negative battery cable. Look under the truck next to the left frame rail directly below the driver seat and you'll see a large 40-pin connector with a bolt in the middle. Loosen that bolt to open the connector and take a look inside. It is not uncommon for water or water w/road salt to get inside causing shorts and corrosion. All circuits that extend past the rear of the cab go through this connector including the wires to the rear axle ABS sensor.
Reply With Quote
  #3  
Old 04-08-2011
Member
Thread Starter
 
Join Date: Apr 2011
Location: mulkeytown ill
Posts: 2
I will check that out, it seems that in the mornings going to work it does it sum and then going home its warmer out and does it alot more
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 07:35 AM
erratic speedo problems Help 2001fordranger 2.9L & 3.0L V6 Tech 2 07-21-2010 12:13 PM
speedo problems JordanD General Technical & Electrical 8 01-02-2009 10:38 AM
Swapped out my cluster for a 02 Explorer w/white faces...speedo problems pastfinder Interior Semi-Tech 14 05-08-2006 10:48 PM
speedo change? blacknight Wheels & Tires Semi-Tech 2 06-15-2004 08:21 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:06 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.