Trucky won't starty - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-29-2006
buzzair's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: White Plains, NY
Posts: 2,341
Trucky won't starty

So, I haven't driven my truck in about a week...

Today, I had been doing some electrical work replacing my new Sirius reciever. The radio wouldn't turn on and as it turns out, I blew a fuse, so I replaced the radio fuse and still nothing. The electrical is coming on, the dash lights and my OHC come on. Then for some reason I decided to start my truck...I got nothing, no sounds, clicking, engine trying to turn over, nada.

I tried jumping it, no go. I switched the blower relay and the starter relay and I heard a loud rapid clicking noise. I thought maybe the starter relay was blown. Went to advanced auto, got a new starter relay...put it in, and nothing at all. No clicking, no sounds.

When I swich the relay again with the blower or other relay, I get the rapid clicking noise.

Any ideas?? Maybe advanced gave me a bad relay?
Reply With Quote
  #2  
Old 06-29-2006
buzzair's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: White Plains, NY
Posts: 2,341
9 views...no comments. la-la-la-la-la....
Reply With Quote
  #3  
Old 06-29-2006
HRoc's Avatar
Member
 
Join Date: Jun 2006
Location: Southern NH
Posts: 144
Did you double check the fuses for the ECU and Starter?

I'd check those to be sure first.

:edit:

This would seem far fetched as I don't know if the electrical systems are similar for an 01 versus a 95..but I would reccomend checking those fuses in your dash first.

Since you mentioned you blew out a fuse trying to hook up your Sirius radio, those could've shorted out as well.
Reply With Quote
  #4  
Old 06-29-2006
mudranger96's Avatar
Member
 
Join Date: Oct 2005
Location: Lehigh Acres, FL
Posts: 2,549
I'd try a different battery
Reply With Quote
  #5  
Old 06-29-2006
buzzair's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: White Plains, NY
Posts: 2,341
Checked all fuses in cab and in engine bay. I replaced the starter relay with a new one.

I'm thinking its not battery since I have aux. Panel lights, OHC, everything comes on. (except radio still).
Reply With Quote
  #6  
Old 06-29-2006
mudranger96's Avatar
Member
 
Join Date: Oct 2005
Location: Lehigh Acres, FL
Posts: 2,549
sometimes your battery could have enough power to turn on your lights but not turn over the engine
Reply With Quote
  #7  
Old 06-29-2006
KARPE's Avatar
Member
 
Join Date: Apr 2005
Location: Valrico, Fl 33594
Posts: 4,748
takes a lot more power to crank an engine than to have a few bulbs light up. If you have a 12V charger, charge up the battery for a few hours, then take it to either an auto parts store or a batteries plus if there are any near you and have them load test it. you need to go ahead and rule the battery out before you just make an assumption that the thing that starts the truck that you have left sitting for a week is probably not the problem.
Reply With Quote
  #8  
Old 06-29-2006
buzzair's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: White Plains, NY
Posts: 2,341
Does it make any difference that it didn't work when I tried to jump start it?

I think my GF"s bro has a charger..I'll go ask him.
Reply With Quote
  #9  
Old 06-29-2006
OffRoad 4x4's Avatar
Member
 
Join Date: Feb 2005
Location: Escondido, CA
Posts: 301
Check the condition of the cable wires and battery terminals looking for white powder (oxidation). This can even cause problems when trying to jump start the vehicle... Remove and clean the terminal and connector....
IF the wiring in the cables is oxidized... then it is time for new cables....
Check the voltage at the battery terminals... Normal is 12.5 to 12.8 VDC....
If less than 12.0 V there is a good chance the battery has a problem.... which may or may not be caused by an alternator that is not charging properly....
Reply With Quote
  #10  
Old 06-29-2006
jtslmn720's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Location: Kent State, Kent Ohio
Posts: 7,367
siounds like what happend to me... once you can get it started then you should be ok, mines on green now after it was on red for almost a week...
Reply With Quote
  #11  
Old 06-29-2006
buzzair's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: White Plains, NY
Posts: 2,341
So thats what it was...the battery. Took it to advanced auto parts and they charged it up for about an hour...for free too. Thanks for all the replies guys.

Just a coincidence that I was trying to get my new sirius reciever and radio to work...and it turns out my battery was dead. lol

Thanks for everyone's help. Muchly appreciated.
Reply With Quote
  #12  
Old 06-29-2006
Ian Ian is offline
Member
 
Join Date: May 2006
Location: Finleyville, PA
Posts: 62
I know this isn't an issue anymore, but thought I'd throw some info out there. I had this exact same problem with my escort that hadn't been started since March. The battery was dead, but it also had a lot of acid crystal buildup on the negative terminal. If you get about a 50/50 mix of water and baking soda, the basic baking soda neutralizes the acid and cleans it up real nice. just use paper towel to wipe it up as it reacts. Once I got it cleaned up I got a solid connection it started right up. Anyway, glad you got her runnin again.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Very weird! Won't start, won't shut off, flashing exterior lights fletcher969 2.9L & 3.0L V6 Tech 4 01-14-2013 06:26 PM
Ranger won't start edgecellent02 2.3L & 2.5L I4 Tech 27 07-22-2008 06:38 PM
Won't go forward and won't go backwards.. TrishaSB General Technical & Electrical 7 04-14-2006 03:25 AM
Help! Help! Engine won't turn over! TDevil General Technical & Electrical 7 03-08-2005 05:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:21 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.