turn signal problems - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-10-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Mount prospect
Posts: 2
Icon5 turn signal problems

i have a 97 4.0, recently i have been having turn signal problems. if i push my hazardous on they work all the time but randomly the turn signal will not work. iv started to notice its when i hit a bump when the signal is on that it willl go off any ideas???? thanks for the help.
Reply With Quote
  #2  
Old 03-10-2012
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Replace the multi function switch, AKA the turn signal switch.
Reply With Quote
  #3  
Old 03-10-2012
Brandon97xlt's Avatar
Member
 
Join Date: Sep 2010
Location: Warsaw, Indiana
Posts: 280
I had the same problem. And it was the turn signal switch. It's not to hard to change as long as you have the right tools.
Reply With Quote
  #4  
Old 03-10-2012
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
just to trouble shoot, if you have the tow package and/or trailer wiring, make sure it isnt shorting out against truck. had that happen before
Reply With Quote
  #5  
Old 03-10-2012
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
If the rear of the truck is shorting out it would be popping the fuse. Or it would light the switch on fire.
Reply With Quote
  #6  
Old 03-11-2012
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
Quote:
Originally Posted by Blhde View Post
If the rear of the truck is shorting out it would be popping the fuse. Or it would light the switch on fire.
never did it to me. in theory it should but it just made my signals mix up and go off whenever
Reply With Quote
  #7  
Old 03-11-2012
Scrambler82's Avatar
Old Guy Userů ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,773
I had a problem with a ’95 Ranger XL, rear lights screwing up and it was the connector on the Multifunction Sw, a couple of ty-wraps and all fixed.
Sold it that way and no problem heard of.
Reply With Quote
  #8  
Old 03-11-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Mount prospect
Posts: 2
thanks for all the help
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Reverse Signal & Parking Break Signal brainbox General Technical & Electrical 5 06-14-2017 08:24 AM
Turn Signal/Taillight Problems danado General Technical & Electrical 2 11-28-2011 04:22 PM
3rd Brake Light Turn signal jtslmn720 General Ford Ranger Discussion 8 10-17-2005 12:57 PM
3rd Brake Light / Turn Signal Mod...How? Buttercup General Technical & Electrical 27 06-19-2005 08:37 AM
LED Turn Signal Mirrors Mykhael General Technical & Electrical 1 10-22-2004 07:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:16 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.