Vechile Speed Sensor Problems - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-17-2014
Member
Thread Starter
 
Join Date: Mar 2014
Location: Jamestown, NC
Posts: 2
Vechile Speed Sensor Problems

Hello,

I am new to this site. This is my second post. I posted a thread in the introduction with a little bit about my Ranger.

I have a 94 3.0 2WD, 5 speed. I have done a bunch of work to it to get it road worthy. My speedometer does not work. My truck has the speedometer cable going down to the mechanical/electro combo speed senor on the transmission (I attached a picture of it). I found that the cable was not attached, just sitting up on the frame. I replace the speed senor and the speedometer cable seems to fit in nice, but there is nothing holding it in. If it just left it like it is, it would most likely just slip out. It seems like there is a clip missing, but I went to a couple of local parts stores, looked at cable and speed sensors none come with retaining clips, and none have listings for them.

Any help would be greatly appreciated.
Attached Thumbnails
Vechile Speed Sensor Problems-vss.gif  
Reply With Quote
  #2  
Old 03-30-2014
Member
 
Join Date: Mar 2014
Location: Abilene
Posts: 14
Transmission Speed Sensor

Slides in but looks like it will come right out. Are you missing the bolt/screw that holds it in place? The pic you attached shows bracket with a hole in it where the bolt goes that holds it in place. I replaced speed sensor on my transmission and on the rear differential. Both were/are held in place by a bolt (metric head). My speedo/odo still does not work.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Replaced ABS speed sensor in a 99 ranger still having problems. Please help Elberto1999 Drivetrain Tech 2 10-17-2014 10:32 AM
5 Speed Auto with Overdrive feels like a 6 speed? patkelly1336 Drivetrain Tech 7 10-06-2012 09:04 PM
Speed sensor plug for a 5-speed manual BlackRanger04 Drivetrain Tech 4 01-04-2011 01:07 AM
temp sensor and speed sensor for ohc BananaEdge Exterior Semi-Tech 4 09-01-2004 11:42 AM
speed sensor BananaEdge Interior Semi-Tech 5 08-28-2004 04:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:42 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.