voltage too high? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-22-2011
morris's Avatar
RF Veteran
Thread Starter
iTrader: (5)
 
Join Date: Feb 2008
Location: South Detroit.
Posts: 7,833
voltage too high?

tonight my UG alarm came on and told me that my battery volts were too high when i started my truck. it had been sitting for 9 hours so i was like wtf!?

anyways, last summer or early fall the battery was tested and produced 12-13 as a reading.
the dealer told me this was in the normal operating range.

since i've installed the UG it's mid 13s to low 14s. sometimes as low as high 12s. tonight my trucks' volts peaked enough to set the alarm at 15.

my question is should i be worried? if there was a problem with my alt wouldn't my volts be too low? my step dad says this is abnormal to him but mentioned i should bring it to the dealer. my warranty expires tomorrow.
Reply With Quote
  #2  
Old 03-22-2011
buggman's Avatar
Member
iTrader: (38)
 
Join Date: Apr 2007
Location: Dougal County
Posts: 1,648
It's normal to get spikes at 15v when it's running, sometimes mine will run at 14.9v at idle.
You could get the alternator checked out to make sure the voltage regulator isn't going bad just to be on the safe side though.

It's a little odd that you have more voltage after the alarm was installed... usually everything new that's added will draw a little current & drop your voltage a tiny bit.
Reply With Quote
  #3  
Old 03-23-2011
morris's Avatar
RF Veteran
Thread Starter
iTrader: (5)
 
Join Date: Feb 2008
Location: South Detroit.
Posts: 7,833
exactly. i was wondering if i was gonna have a dead battery with the problems mentioned on the UG forum. i think i'll stop by the dealer anyways and see what they say. if they give me problems, what does a new voltage regulator cost? is it separate from the alt or would i have to replace that?

EDIT: i just called the dealer about sneaking in an apt and the service guy said this could happen upon start up depending on the load on the engine and what accessories are turned on. he said if it was a constant alarm then there would be some concern but this isn't major and to just keep an eye on it. i ran the UG for codes but nothing came up.

Last edited by morris; 03-23-2011 at 08:03 AM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Alternator Voltage and Voltage Drop at high RPM Derek_Z10 General Technical & Electrical 9 05-09-2014 10:55 PM
Truck too old? ELM327 too cheap? Computer gone bad? ccernst General Ford Ranger Discussion 1 04-25-2013 09:31 PM
Battery Light, High voltage jagazzflatts General Ford Ranger Discussion 4 05-29-2011 10:37 PM
Too many ideas, too little funds ScottG Snapshots 15 03-30-2008 12:09 PM
Too Body Lift... Or Not Too Body Lift... Mason 1" & 3" Body Lifts 51 06-30-2005 10:09 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:54 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.