What the crap!!?? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-26-2007
Member
Thread Starter
 
Join Date: Aug 2006
Location: Tupelo, MS
Posts: 34
What the crap!!??

So im riding around the other night and my radio turns off...I get home and check for blown fuses and they are all fine. So now my radio wont come on and my windows wont roll down. All of my lights on the inside still work and all of my 12v power supplies.
Reply With Quote
  #2  
Old 02-26-2007
RF Veteran
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
What kind of radio do you have? does it have an internal fuse?
Reply With Quote
  #3  
Old 02-26-2007
telemaster1952's Avatar
Member
 
Join Date: Dec 2005
Location: Dover, Deleware
Posts: 3,481
some of them have a fuse on the back of the unit. take the keys and pull it out. check that first. i had the same thing on my pioneer hu
Reply With Quote
  #4  
Old 02-26-2007
franger's Avatar
Member
 
Join Date: Dec 2006
Location: litchfield,ct
Posts: 271
im jus curiuos bud did you recently get a new stereo hooked up, like subwoofers and amp?


mike
Reply With Quote
  #5  
Old 02-26-2007
Member
Thread Starter
 
Join Date: Aug 2006
Location: Tupelo, MS
Posts: 34
Okay ill pull it out and try that. Yeah i just put in two 8" L7s and a 1200 watt amp
Reply With Quote
  #6  
Old 02-27-2007
Member
Thread Starter
 
Join Date: Aug 2006
Location: Tupelo, MS
Posts: 34
Okay i pulled the radio out and there isn't a fuse on the back of it. I can't figure out why the radio going off will cause my windows not to work. My mirror switch works and my door locks, but my windows wont do anything.... I need
Reply With Quote
  #7  
Old 02-27-2007
HighRollerII's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Jun 2004
Location: Charleston, SC
Posts: 10,066
you got a test light..start checkin wires
Reply With Quote
  #8  
Old 02-27-2007
franger's Avatar
Member
 
Join Date: Dec 2006
Location: litchfield,ct
Posts: 271
well the reason i asked if you got subs/amps hooked up lately is b/c my friend went somewhere to get this all done at the local stereo installation store, and they screwed up big time.w hat they did was they wired the subs/amp to the power windows adn fried that, therefor making the power windows not able to function properly.


mike
Reply With Quote
  #9  
Old 02-27-2007
Member
Thread Starter
 
Join Date: Aug 2006
Location: Tupelo, MS
Posts: 34
Well i hooked up my system.. I have hooked up three or four before mine so i dont think it was anything i done wrong.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
new exhaust and truck runs like crap duff daddy SOHC - 2.3L & 2.5L Lima Engines 14 09-26-2005 02:39 PM
tires look like crap.. ripcurrent88 Wheels & Tires Semi-Tech 12 06-18-2005 12:44 PM
HOLY CRAP - my new system Chodemnky Audio & Video Tech 8 06-07-2005 12:36 PM
what the crap is this? TippnOver Ranger-Forums Office 25 03-16-2005 10:51 AM
Crap... eXtremePC Drivetrain Tech 6 02-10-2005 04:27 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:47 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.