wont stay running - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-17-2009
Member
Thread Starter
 
Join Date: Sep 2008
Location: hurlburt field, FL
Posts: 10
wont stay running

almost 2 years ago i bought a 91 2.9L 4x4 ranger off a buddy of mine. When i bought it, it didn't start until i replaced the battery and cables. Since I've had the truck I've replaced a few parts that went bad; radiator, starter, right side exhaust manifold, fuel pump, master cylinder, and rotors. i drove the truck for about six months until i joined the air force. Between basic and tech school i was gone for about 8 months. when i returned home at the end of may the truck started and after about five minutes or so of keeping it at 3k RPMs or so it would idle. only being home on leave i soon went to my base in FL, and in august i had the truck shipped down. well, on arrival the truck wouldn't start, wouldn't even crank. since I'm still relatively new to the world of mechanics i had one of the guys at the shop help me and we attempted to troubleshoot what the issue was. the truck would only attempt to start by crossing the solenoid with a charger on the battery. the man helping me said it was out of time. So, over a series of saturday mornings i replaced the timing gears/chain and tensioner, and he suggested the oil pump, so that got replaced too. once i got it back together it still wouldn't start, i know the engine is in time now though. the old battery wasn't holding a charge so i bought a new one. i also siphoned out the old gas and put new gas into it, at this point its been sitting for a year. once we rotated the distributor a bit, it fired up, but is still having issues. it will only stay running if i keep the RPMs up and even then, it can barely push its own weight.. it was poorly maintained by the guy who owned it before my buddy (he got the truck from his uncle for free, but doesn't drive). when i first bought it, the radiator was zip-tied into place, and there was, and still is a small c-clamp holding on one side of the distributor cap. im too stubborn to get rid of the truck and dont have the money to drop a new motor in it yet. can somebody please help me?
Reply With Quote
  #2  
Old 12-17-2009
bjohnson238's Avatar
Member
 
Join Date: Nov 2008
Location: Muncie, IN
Posts: 732
So it cranks over but won't fire at all, or it fires and dies?
Reply With Quote
  #3  
Old 12-18-2009
Member
Thread Starter
 
Join Date: Sep 2008
Location: hurlburt field, FL
Posts: 10
it fires....barely. have to pin the gas pedal and even then it has to build enough RPMs to start. its like its only using 2 of the cylinders to do all the work.
Reply With Quote
  #4  
Old 12-18-2009
bjohnson238's Avatar
Member
 
Join Date: Nov 2008
Location: Muncie, IN
Posts: 732
Kinda sounds like a fuel issue or a vacuum leak. Do you have a way to test the fuel pressure?
Reply With Quote
  #5  
Old 12-18-2009
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
Start off with a compression tester see how much compression you have on all six cyl. The basic's for a gaser engine to run is fuel air and spark if you have all three she will run. Sounds like it could be a blown head gasket or a cracked head (worse case). Have you replaced the plugs and wires cap and rotor. Also test the coil take the #1 spark plug wire off and put a screw driver in the spark plug wire have someone crank the engine you should have a bright blue spark if not your coil might be bad or you could have a bad connection some where two years sitting is not good for that . Lets see....If i think of anything else ill post. Let us know how everything work's out for ya!
Reply With Quote
  #6  
Old 12-18-2009
Member
Thread Starter
 
Join Date: Sep 2008
Location: hurlburt field, FL
Posts: 10
its got fuel pressure, new plugs, wires, cap, and rotor. this weekend im gonna put a new coil on it. one of my superior said that the timing could be backwards, but i dont think that is it, when i replaced the timing kit, the dots on the gears were lined up/ pointing towards each other. when the engine is at top dead center the rotor is pointing to the firewall.
Reply With Quote
  #7  
Old 12-19-2009
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
No i really doubt the timing is 180 out as it would fire but through the intake/ex . Like i said check spark and compression. Let us know how she goes for ya!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Won't Stay Warm? White Lighting SOHC - 2.3L & 2.5L Lima Engines 4 01-24-2013 09:32 AM
Wont stay running MCM5595 4.0L OHV & SOHC V6 Tech 1 08-16-2011 08:14 PM
Peg That Aligns Headlight Wont Stay On? Roach2004 General Ford Ranger Discussion 16 08-29-2009 07:57 PM
91 Ranger, 4cyl automatic wont stay in OD(4th gear) cabech984 Drivetrain Tech 1 01-22-2008 11:41 AM
wont stay started jdmyers 4.0L OHV & SOHC V6 Tech 5 09-04-2007 09:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:56 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.