in a pinch - Ranger-Forums - The Ultimate Ford Ranger Resource


Member Introductions New to Ranger-Forums.com? Please take a moment and introduce yourself.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-11-2011
Member
Thread Starter
 
Join Date: Jul 2011
Location: Prague, OK
Posts: 1
in a pinch

Hey everyony my name is josh, I am from Prague oklahoma. thought i would talk to some people who really know what might be going on. I have a new battery and alternator and it stll won't charge the battery.
Reply With Quote
  #2  
Old 07-11-2011
Dirty Ranger's Avatar
Member
 
Join Date: Jan 2011
Location: Ontario, Canada
Posts: 456
did u check the cables , u may be grounded out some where , my buddy had the same issue with his 96 ranger and it turned out the positive cable was bad , he had changed the negitive cable in the future so it was good , also make sure the connections are clean
Reply With Quote
  #3  
Old 07-11-2011
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
did you upgrade the alternator or replace with oem? when i did mine i just wired the alternator directly to the battery.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
slightly redneckjimmyriggin fixes in a pinch! darangerdanger General Ford Ranger Discussion 38 10-01-2010 09:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:30 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.