my truck hits hard - Ranger-Forums - The Ultimate Ford Ranger Resource


Snapshots Share photos of vehicles in this sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-03-2010
scott5640's Avatar
Member
Thread Starter
iTrader: (-1)
 
Join Date: Mar 2009
Location: Davenport FL
Posts: 901
my truck hits hard

Reply With Quote
  #2  
Old 05-03-2010
haydnclement4's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: paso robles, ca
Posts: 148
what setup you runnin? sounds good!
Reply With Quote
  #3  
Old 05-03-2010
scott5640's Avatar
Member
Thread Starter
iTrader: (-1)
 
Join Date: Mar 2009
Location: Davenport FL
Posts: 901
12 inch 400 watt orion sub and a jensen power 400 watt amp
Reply With Quote
  #4  
Old 05-03-2010
bonez's Avatar
Member
 
Join Date: Nov 2008
Location: Toronto, Ontario
Posts: 433
now imagine how much better it would sound with a proper amp!

and a better sub.

sounds good tho.
Reply With Quote
  #5  
Old 05-04-2010
Metro55's Avatar
Member
 
Join Date: Apr 2009
Location: Winnipeg
Posts: 938
hardly hard.. only a 400w amp.. on a max 400w sub..?
Reply With Quote
  #6  
Old 05-04-2010
Member
 
Join Date: Jun 2007
Location: Killafornia
Posts: 1,523
lolz
Reply With Quote
  #7  
Old 05-04-2010
rstangboi's Avatar
Member
 
Join Date: Jan 2008
Location: Davis, Ca
Posts: 2,583
Quote:
Originally Posted by Metro55 View Post
hardly hard.. only a 400w amp.. on a max 400w sub..?
you said it for me lol
Reply With Quote
  #8  
Old 05-04-2010
Member
 
Join Date: Apr 2010
Location: kokomo
Posts: 25
lol my sony explodes 6x9's are rated at 400watts
Reply With Quote
  #9  
Old 05-04-2010
scott5640's Avatar
Member
Thread Starter
iTrader: (-1)
 
Join Date: Mar 2009
Location: Davenport FL
Posts: 901
its better than nothing at all
Reply With Quote
  #10  
Old 05-04-2010
Metro55's Avatar
Member
 
Join Date: Apr 2009
Location: Winnipeg
Posts: 938
mine doesn't even hit VERY hard with 2 12" Alpine R's with 700 watt running to each..
Reply With Quote
  #11  
Old 05-04-2010
rstangboi's Avatar
Member
 
Join Date: Jan 2008
Location: Davis, Ca
Posts: 2,583
ya....i thought my one 18" did...or my two 15"s.....but my friends single 15" killed me...it really is all in the box.
Reply With Quote
  #12  
Old 05-04-2010
Vonhanson's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2009
Location: Glencoe, Minnesota
Posts: 1,609
i guess thats hard.

what will my new system be?

single Aq HDC3 10' sub with the AQ 2200 Amp on it.

i got my sub ordered and box planned just gotta make it yet.
Reply With Quote
  #13  
Old 06-17-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
What song is that?
Reply With Quote
  #14  
Old 06-17-2010
sonicbluestx's Avatar
Member
iTrader: (1)
 
Join Date: Apr 2009
Location: Dover Delaware
Posts: 315
well my pathetic 8's in a tiny box with a ****ty amp metered at 131.7db is that hard?
Reply With Quote
  #15  
Old 06-17-2010
David N's Avatar
Member
 
Join Date: Dec 2008
Location: Williamston, NC
Posts: 1,060
Haha. I like that!
Reply With Quote
  #16  
Old 06-17-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
When I get my new 12" finished I want to get my truck metered.
Reply With Quote
  #17  
Old 06-17-2010
Vonhanson's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2009
Location: Glencoe, Minnesota
Posts: 1,609
tyler, i've thought about buying a meter(its like 600 bucks tho) and just charge 10-20 bucks to meter people to work the money back. but i'd really like to get mine metered as well.

did you order your sub yet? and are you getting copper or alum coils?
Reply With Quote
  #18  
Old 06-17-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
Yea I ordered it last night. Also ordered a good bit of 0g and batt. terminals for the 0g and some really nice RCA's. My coils are the copper ones.
Reply With Quote
  #19  
Old 06-17-2010
Vonhanson's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2009
Location: Glencoe, Minnesota
Posts: 1,609
yeah, if your going at like 1500 ish rms to it, i'd say with big 3 and a better battery up front you'd be fine

but anything over that i'd add a second battery to the back, and maybe expo alt (130ish Amps i think) vs rangers 90 or 95 whatever mine is.

alum are stronger (cost more) but copper you can still put over 2k rms on it if you know what your doing, first time i put my aq 1200 on it i was like damn i should of went bigger but the sub is finally getting a little looser so it hits pretty good now.
Reply With Quote
  #20  
Old 06-17-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
Yea I know a good bit of what I'm doing ahah and for the things I don't know about, I know how to do some research. I am going to be running hopefully about 1700-2k rms.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Oil light stays on until engine hits full operating temp, used to do the opposite BuckGodot 2.9L & 3.0L V6 Tech 1 02-17-2012 05:16 AM
Tailpipe hits leaf spring... what can I do? FULLSCALE General Technical & Electrical 13 05-31-2010 11:54 PM
weird clunking i hear when my truck hits a bump kingwoodranger Suspension Tech 4 12-30-2009 01:37 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.