ABS light almost always on?? - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-09-2011
Member
Thread Starter
 
Join Date: Nov 2011
Location: Texas
Posts: 9
ABS light almost always on??

My ABS light turns on quite often... Almost all the time. There is no difference in how it drives or anything it'll just randomly be on. It will turn on and off sometimes too.. Any ideas?
Reply With Quote
  #2  
Old 12-09-2011
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Before checking anything else, be sure that the brake fluid level is at the MAX line. If that's OK, have a shop check for ABS codes.
Reply With Quote
  #3  
Old 12-09-2011
Member
Thread Starter
 
Join Date: Nov 2011
Location: Texas
Posts: 9
I think it might be my ultragauge causing it... apparently it's a known issue in tacomas...
Reply With Quote
  #4  
Old 12-09-2011
AJinUT's Avatar
Member
 
Join Date: May 2011
Location: riverton, UT
Posts: 45
my hub went bad in my truck and the abs light was on sometimes at first then when it got worse it was all the time .
Reply With Quote
  #5  
Old 12-09-2011
Member
Thread Starter
 
Join Date: Nov 2011
Location: Texas
Posts: 9
Did it drive different though? Cause mine still drives fine...
Reply With Quote
  #6  
Old 12-09-2011
AJinUT's Avatar
Member
 
Join Date: May 2011
Location: riverton, UT
Posts: 45
Nope never felt it drive different. Once it got worse you could here it . And if you jacked it up and grabbed the top and bottom of the tire it had some play in it
Reply With Quote
  #7  
Old 12-09-2011
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
first of all what year is your truck/ is it 2wd or 4wd? make a signature...it will make all of our lives easier...click on the link in my sig and it will show you how to make one
Reply With Quote
  #8  
Old 12-09-2011
Member
Thread Starter
 
Join Date: Nov 2011
Location: Texas
Posts: 9
Done... And it's a 96 2wd

Well it said it saved and the thing is checked to show my signature...
Reply With Quote
  #9  
Old 12-09-2011
Member
Thread Starter
 
Join Date: Nov 2011
Location: Texas
Posts: 9
Test
Reply With Quote
  #10  
Old 12-10-2011
Brandon97xlt's Avatar
Member
 
Join Date: Sep 2010
Location: Warsaw, Indiana
Posts: 280
I had this same problem. I just replaced the sensor underneath the break fluid resiviour but the only place I could find the part is at the stealership. And you should get it fixed soon cuz if the light is on that means your ABS is not working.
Reply With Quote
  #11  
Old 12-10-2011
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
trouble shoot before replacing: have you gone over the wiring to discover faulty fuse? broken wire? corroded wire? etc. sounds like a sensor but I would hate to dish out the green for something you dont need
Reply With Quote
  #12  
Old 12-10-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
He only has rear wheel ABS.
You most likely have a wiring issue. there is an ABS module under your truck that the plugs in on the bottom. if any of those wires get messed up, the ABS light comes on. I'd make sure that all the wires are good and that there isn't any corrosion.
This happens to my truck all the time. i'd be willing to bet that in heavy rain the ABS light goes off too.
Reply With Quote
  #13  
Old 12-10-2011
Member
Thread Starter
 
Join Date: Nov 2011
Location: Texas
Posts: 9
Where exactly is the module? Sorry I'm kind of a noob at some of this lol... I was a mechanical engineering major though so I can figure it out when I know where to look. Thanks for the help!
Reply With Quote
  #14  
Old 01-21-2012
hozII's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: athens, Al
Posts: 2,245
Could also be the abs/speed sensor on top of diff.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
almost(ALMOST) too good of a deal to pass up haha darangerdanger General Ford Ranger Discussion 17 08-25-2010 02:29 PM
Almost done pics...almost...new paint! wvcat Snapshots 38 06-18-2009 06:13 AM
New ABS sensor, now ABS light. 01xltranger4x4 Drivetrain Tech 32 06-26-2007 06:24 PM
damned ABS, battery and Brake lights always on! 98rang General Technical & Electrical 5 04-13-2007 08:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.