brakes - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-19-2008
Member
Thread Starter
 
Join Date: Oct 2007
Location: reynoldsburg, ohio
Posts: 34
brakes

I was pulling out of my driveway the other day and my brakes were extremely loose, like id have to put the pedal to the floor just to get ne brakeage. I checked the brake fluid level and it was full and i just got new pads and roters on a couple months ago... ne suggestions bout what could be wrong would be very helpful.
Reply With Quote
  #2  
Old 04-20-2008
Member
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
possibly air in the brake line....have u tried bleeding the brakes? thats all i could think of it wouldnt make sense that it was doing it now though
Reply With Quote
  #3  
Old 04-20-2008
94rangerguy2007's Avatar
Member
 
Join Date: Apr 2007
Location: fort myers,fl
Posts: 31
Check Your Back Brakes. My Backs Came A Part Do To Over Self Ajusting. Now All Good.
Reply With Quote
  #4  
Old 04-21-2008
bergs's Avatar
Member
 
Join Date: Sep 2007
Location: Arizona Bay
Posts: 151
+1 on checking the shoes

I am currently going through this at the moment...truck's been down a week and I just found the issue today.

The lower shoe spring came off which allowed the adjuster to fall out of the shoes and reside in the bottom of the drum......and this whole time I thought it was a bad master....
Reply With Quote
  #5  
Old 04-22-2008
Member
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
lol thats probably same reason i have no e brake....maybe if i get a day of work i will replace shoes and fix
Reply With Quote
  #6  
Old 05-05-2008
Jmhm17's Avatar
Member
 
Join Date: Oct 2007
Location: Worcester, MA
Posts: 534
i replaced both adjusters in mine and mine do the same thing all the time every once in a while they will grab but most of the time my brakes suck, they either lock up in the rear unexpectedly or they dont grab at all.. i cant figure out whats wrong, if i adjust then i have good brakes for about 2 days then its back to the way it was. the only thing i havent replaced yet is the hardware for the shoes... its obviusly my adjusters since they work after i adjust them, if it was air int he lines it would be a problem even after i adjusted them its like the little clip keeps spinning off the spur and no matter what i do i cant get it to stay adjusted.. anyone else have this problem?
Reply With Quote
  #7  
Old 05-11-2008
Member
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
hell i tried to change my rears and one of the shoes was stuck to the drum
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
9" brakes or 10" brakes Runarenis 4.0L OHV & SOHC V6 Tech 12 08-21-2011 11:55 PM
failed inspection all brakes and axle seals ryan_88 Drivetrain Tech 8 09-25-2008 03:55 PM
I have no brakes???? DaytonaBchRanger Suspension Tech 11 10-17-2004 11:49 PM
brakes help BananaEdge General Technical & Electrical 4 10-16-2004 06:30 PM
Rear drum brakes DownSouthTAS General Technical & Electrical 1 06-10-2004 06:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:23 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.