Crank no start b2300 HELPPP - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-02-2011
Member
Thread Starter
 
Join Date: May 2010
Location: Pennington NJ
Posts: 26
Crank no start b2300 HELPPP

So the other day the mazda b2300 was at a light and it stalled. Didnt bog down or anything. just shut off. It cranks but wont start, its not even trying. I have spark from the coil pack to the wires (the wires and plugs are less than a year old and unless they all went bad simultaneously im gonna assume theyre fine). The fuel pump primes when the key is turned. The truck does have 226xxx miles but has run like a champ until now. I am at a loss for what to check next though! Maybe the PCM? HELPPPPPPPPP
Reply With Quote
  #2  
Old 06-02-2011
Member
 
Join Date: May 2011
Location: clayton
Posts: 5
Belt?
Reply With Quote
  #3  
Old 06-02-2011
Member
Thread Starter
 
Join Date: May 2010
Location: Pennington NJ
Posts: 26
timing belt? There were no funny noises when the motor stopped. is the 4 banger a non interference motor? that would make sense then?
Reply With Quote
  #4  
Old 06-02-2011
Member
 
Join Date: May 2011
Location: clayton
Posts: 5
I don't know I have a 2000 ranger with the 2.5 Lima motor which is non interference. My belt broke at 190k.
Reply With Quote
  #5  
Old 06-07-2011
Member
Thread Starter
 
Join Date: May 2010
Location: Pennington NJ
Posts: 26
How do you test a PCM?
Reply With Quote
  #6  
Old 06-07-2011
Member
 
Join Date: Feb 2011
Location: Ontario, Canada
Posts: 27
Some info would be nice. Year and engine size would be cool.

So the spark plugs spark? For sure? The fuel pump runs? Even when it's cranking? Means its got spark and fuel. So that leaves compression issues (todays engines usually never have air issues that cause a complete no start, unless it's a sensor, so I am omitting that), and it would seem to me the timing belt either skipped or is broken.

Yet, it could also be a sensor. It might be a Crank Angle Sensor or a Crankshaft Position Sensor gone faulty. Also, does the CEL light up at all when you turn the ignition to "ON"? If it doesn't, I'd suspect a PCM.
Reply With Quote
  #7  
Old 06-07-2011
Member
Thread Starter
 
Join Date: May 2010
Location: Pennington NJ
Posts: 26
Yeh i thought it could be a crank angle sensor but then i found out it was a non interference motor. Pulled the timing cover back and sure enough the cam wasnt turning while cranking.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1988 2.3L Ranger won't start, only crank CLAARMAN SOHC - 2.3L & 2.5L Lima Engines 6 07-02-2014 08:23 PM
Swapped engines, wont start, transmission spins, crank doesnt. 503_94ranger_541 Drivetrain Tech 40 10-23-2009 08:58 PM
Won't crank/start! Please help! Brandon77 General Technical & Electrical 21 09-16-2009 04:37 PM
crank no start need help 4x4ranger 4.0L OHV & SOHC V6 Tech 0 06-13-2009 06:41 AM
Crank, crank, crank xXcecinestpasXx86 General Technical & Electrical 7 05-08-2009 11:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:13 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.