Need some help - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-15-2009
Member
Thread Starter
 
Join Date: Oct 2009
Location: Des Moines, IA
Posts: 6
Need some help

Need some help I've got a '91Ranger 5 speed, that won't start when I push the clutch in. Anybody else have a problem like this? I was thinking it could either be a neutral safety switch or a bad connection on the electrical system. Just looking for some ideas.

Edit: It does not turn over when Ignition is turned, nothing happens.

Last edited by Burnin; 10-15-2009 at 11:25 PM.
Reply With Quote
  #2  
Old 10-16-2009
Bryan22's Avatar
Member
 
Join Date: Nov 2008
Location: Lancaster, ca
Posts: 211
no click or anything? probably is a bad switch if you've got power and it's not even clicking. you could try bypassing the switch and see if it will start.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Some Camburg, some BTF, some Bilstein, some OEM yeatzee Snapshots 17 08-14-2012 05:17 PM
I need new shocks and i need some help 2007BlackFX4 Suspension Tech 3 06-03-2010 08:36 PM
Some Snow, Some Flex, and Some Stuck (56k No Way) MothMan999 Snapshots 31 12-24-2009 10:08 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.