Speed Problem Please HELP!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-23-2006
Member
Thread Starter
 
Join Date: Sep 2006
Location: Griffin, Ga
Posts: 4
Speed Problem Please HELP!!!!

96 Ranger 5-speed. i have a problem with the truck and dont know what it is? Its like when im driving and let off the gas pedal it feels like the transmission drops down a gear, but it doesnt. it just started today and its freaking me out. PLEASE help if you understand the problem PLEASE
WHYTE MIKE
Reply With Quote
  #2  
Old 10-24-2006
Member
 
Join Date: Dec 2005
Location: MI, U.S.A.
Posts: 322
you may want to check your u-joints, if there worn badly, they could make a slight jerk when letting off the gas, also when you get back on the gas.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Replaced ABS speed sensor in a 99 ranger still having problems. Please help Elberto1999 Drivetrain Tech 2 10-17-2014 10:32 AM
PLEASE PLEASE PLEASE.... annguyen1981 General Ford Ranger Discussion 13 12-05-2013 03:35 PM
5 Speed Auto with Overdrive feels like a 6 speed? patkelly1336 Drivetrain Tech 7 10-06-2012 09:04 PM
Speed sensor plug for a 5-speed manual BlackRanger04 Drivetrain Tech 4 01-04-2011 01:07 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.