Starter keeps running. - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-21-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Fort Wayne, IN.
Posts: 40
Icon5 Starter keeps running.

After the truck starts the starter keeps running.
I replaced the ignition cylinder lock the other day.
Even after I turn key to off position and remove the key, the engine & the starter keep running.
Pulled the starter, had it tested at 2 different places, both times it passed.
It disengaged for them, but not for me.
The solenoid wouldn't make it not disengage would it ?
Could it be a bad Ignition switch ?
The Ignition Cylinder Lock I bought was only $17.
http://www.autozone.com/autozone/par...8_319620_5934_
Reply With Quote
  #2  
Old 04-21-2012
Member
 
Join Date: Feb 2012
Location: Windsor, WI
Posts: 93
Quote:
Originally Posted by Vern View Post
After the truck starts the starter keeps running.
I replaced the ignition cylinder lock the other day.
Even after I turn key to off position and remove the key, the engine & the starter keep running.
Pulled the starter, had it tested at 2 different places, both times it passed.
It disengaged for them, but not for me.
The solenoid wouldn't make it not disengage would it ?
Could it be a bad Ignition switch ?
The Ignition Cylinder Lock I bought was only $17.
http://www.autozone.com/autozone/par...8_319620_5934_
You may want to disconnect the ignition switch conector and see if any terminals are burnt.
Reply With Quote
  #3  
Old 04-21-2012
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Quote:
Originally Posted by Vern View Post
After the truck starts the starter keeps running.
I replaced the ignition cylinder lock the other day.
Even after I turn key to off position and remove the key, the engine & the starter keep running.
Pulled the starter, had it tested at 2 different places, both times it passed.
It disengaged for them, but not for me.
The solenoid wouldn't make it not disengage would it ?
Could it be a bad Ignition switch ?
The Ignition Cylinder Lock I bought was only $17.
http://www.autozone.com/autozone/par...8_319620_5934_
Did this just start after replacing the ignition lock cylinder? If not, disconnect the wire at the S terminal of the fender mounted solenoid. Take a test light or VOM and connect it to the wire. Turn the key to on, then to the start position, then run position while noting the test light or VOM. If the light or VOM shows power other than in the start position Id suspect a bad ignition switch.
Reply With Quote
  #4  
Old 04-21-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Fort Wayne, IN.
Posts: 40
Quote:
Originally Posted by Rev View Post
Did this just start after replacing the ignition lock cylinder?

Yes, it only started & disengaged for about 5 regular start ups.
Reply With Quote
  #5  
Old 04-22-2012
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Quote:
Originally Posted by Vern View Post
Yes, it only started & disengaged for about 5 regular start ups.
You might try removing the lock cylinder ensuring everything's line up properly and reinstalling the lock cylinder.
Reply With Quote
  #6  
Old 04-22-2012
Ardy's Avatar
Member
 
Join Date: Aug 2010
Location: Windsor NS
Posts: 276
My truck did that several times, found that it was the solenoid. Replacing that is easy and cheap.
Reply With Quote
  #7  
Old 04-22-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Fort Wayne, IN.
Posts: 40
Well if I push start it, putting the key in run position, but not engaging the starter, the truck will turn off just fine with the key.
It's just when I use the starter, that the motor & starter won't turn off with the key.
Reply With Quote
  #8  
Old 04-26-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Fort Wayne, IN.
Posts: 40
Did the easy one first, not the solenoid.
Reply With Quote
  #9  
Old 04-28-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Fort Wayne, IN.
Posts: 40
On the road again...
Bad Bendix.
Reply With Quote
  #10  
Old 04-29-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: Fort Wayne, IN.
Posts: 40
Thanks for the advise Rev & tempfixit.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fuel pump keeps running richard General Technical & Electrical 1 05-23-2011 07:56 PM
Ranger keeps flooding itself while running then clears up again. fatalerror General Ford Ranger Discussion 2 07-02-2010 09:59 PM
battery keeps draining dangerranger General Ford Ranger Discussion 12 08-09-2006 02:22 PM
Radar keeps falling off the windshield a311fanam General Ford Ranger Discussion 14 03-25-2006 07:53 PM
"Door Ajar" light keeps coming on Huntress General Technical & Electrical 4 04-10-2005 06:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:34 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.