Didnt work - Ranger-Forums - The Ultimate Ford Ranger Resource


Suspension Tech General discussion of suspension for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-04-2008
S10Killer's Avatar
Member
Thread Starter
 
Join Date: Apr 2008
Location: SO CAL
Posts: 381
Icon5 Didnt work

so my friend bought a lift for like $300.00 and we tryed to install it. but when i tryed to take the spindel off on the right side, the top ball joint was no problem, the bottom wolld not come off at all, i even used my air hammer to get it off but nothing. the only thing i could think of was to nock off the lower ball joint and just replace it with a new one for the lift but i dont know. ANY IDEAS????????????
Reply With Quote
  #2  
Old 05-05-2008
Prerunner-Ranger's Avatar
Level I Supporter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
You gotta hit that crap pretty hard.
Reply With Quote
  #3  
Old 05-05-2008
Alon's Avatar
Member
iTrader: (13)
 
Join Date: Jun 2004
Location: Long Beach, CA
Posts: 2,555
Where are you hitting? You need to hit the spindle, not the balljoint. Try using a steel hammer, not a dead blow if that isnt working. You can also go buy a pickle fork and that should get it off pretty easy.
Reply With Quote
  #4  
Old 05-05-2008
S10Killer's Avatar
Member
Thread Starter
 
Join Date: Apr 2008
Location: SO CAL
Posts: 381
i was hitting the spindel. but still didnt budge for like one hour no joke lol
Reply With Quote
  #5  
Old 05-05-2008
LowMaz's Avatar
Member
 
Join Date: Feb 2007
Location: Sterling/ Amherst, MA
Posts: 788
get the pickle fork and beat it hard. autozone has them as part of their "free loan a tool service".

pay the deposit, use the tool, return it and get your money back
Reply With Quote
  #6  
Old 05-05-2008
Alon's Avatar
Member
iTrader: (13)
 
Join Date: Jun 2004
Location: Long Beach, CA
Posts: 2,555
If you're still stuck tomorrow night, give me a call and I'll see if i can help.

626-272-6322
Reply With Quote
  #7  
Old 05-05-2008
S10Killer's Avatar
Member
Thread Starter
 
Join Date: Apr 2008
Location: SO CAL
Posts: 381
oh ok thght thanks
Reply With Quote
  #8  
Old 05-05-2008
Roach2004's Avatar
RF Veteran
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
Yea its a pain in the ***!!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
It didnt even look like mud CBFranger Snapshots 20 05-26-2009 09:52 PM
Another painting question...search didnt help madripor Interior Semi-Tech 9 05-23-2007 02:18 PM
Radio Bezel paintagain -sry search didnt help 03Edge4.0 Interior Semi-Tech 13 05-07-2006 09:07 PM
I didnt know Maxxis made automotive tires. FoMoCoFiddy Wheels & Tires Semi-Tech 12 03-15-2005 12:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:17 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.