One problem after another - Ranger-Forums - The Ultimate Ford Ranger Resource


Suspension Tech General discussion of suspension for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-16-2006
Sychodemeanor's Avatar
Member
Thread Starter
 
Join Date: Jun 2005
Location: Houston TX
Posts: 213
One problem after another

Ok so I replaced my upper control arms with the MOOGs and also my lower balljoints...all without a problem. I did however notice that my steering components are in need of replacement as well. (tie-rod ends?) Anywho now when I drive the truck and hit a pretty decent bump/dip I occasionlly here a pop/clank. Could this be those parts that I am 100% possitive need replacing making this noise? I figured since the balljoints were so bad off before that I never noticed that noise, or since I had to break that connection on the shackle that it just finished them off. What do ya think? I double checked every nut/bolt after driving and settling to make sure all was tight...


help...
Reply With Quote
  #2  
Old 05-16-2006
TReff's Avatar
Member
 
Join Date: Jun 2004
Location: La Porte,Tx
Posts: 905
sway bar links and/or sway bar bushings.....
Reply With Quote
  #3  
Old 05-16-2006
Sychodemeanor's Avatar
Member
Thread Starter
 
Join Date: Jun 2005
Location: Houston TX
Posts: 213
I was thinking possibly that because I went down an empty road and went crazy swerving the truck left to right and it never once popped...not at all and i mean it was to the point the tires were sqwallin from the driving.
Reply With Quote
  #4  
Old 05-17-2006
Sychodemeanor's Avatar
Member
Thread Starter
 
Join Date: Jun 2005
Location: Houston TX
Posts: 213
No body else here has any thoughts or experience to add to this? John? Anyone?
Reply With Quote
  #5  
Old 05-17-2006
a311fanam's Avatar
Member
 
Join Date: Dec 2004
Location: Westerly, RI
Posts: 2,006
my truck makes that same poping noise when going over bumps when the wheel is turned. It will not make the poping noise when swerving the truck side to side
Reply With Quote
  #6  
Old 05-17-2006
crazy_spl's Avatar
Member
 
Join Date: Apr 2005
Location: London
Posts: 20
i've had all the same problems. I changed all my ball joints because i thought it was them. They where falling out but it wasn't them making the popping sound. I changed my swaybar links, NOPE. It turns out it's a popping noise coming out of my rack. I'm going to change it and the tie rods. When the truck is off and I turn the steering wheel I can hear it popping and clanking.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
what is going on getting a code for parts i replaced after i replaced another part 894banger General Ford Ranger Discussion 4 05-11-2011 09:45 PM
Just some updated shots of the 150. Check it out, Stock/After/After FoMoCoFiddy Snapshots 18 02-22-2010 01:16 PM
Alright it's time for another BEFORE/AFTER thread! Sonic04Edge Snapshots 112 07-23-2008 11:35 PM
One Bank Lean one perfectly fine? INT3RC3PTOR 8-Cylinder Tech 18 02-27-2008 09:53 PM
One problem leads to another. RangerMuse General Ford Ranger Discussion 8 12-12-2007 09:54 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.