Help! Starting issues - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums General Forum Arrow General Ford Ranger Discussion

General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 05-13-2014
Thread Starter

I am: Patrick Manuel
Join Date: Mar 2014
Location: Boring, Oregon
Vehicle: 1994 Ford ranger
Drive Type: 4x2
Engine: 2.3
Posts: 2
Total Props: 0
Help! Starting issues

Hey, I have a '94 ranger 2wd 5 speed with the 2.3 4 banger. My battery terminals were corroded and so I went and bought some new ones. My truck ran and drove before I put them on(was my daily driver) but now it won't start. I'm not getting fuel or spark. The fuel pump doesn't whirr when I turn the key on. It cranks over fine, but will not fire. I replaced the EEC Relay and no luck.any ideas?
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
'93 4.0-starting/tach issues racsan 4.0L OHV & SOHC V6 Tech 1 01-11-2011 07:55 PM
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 10:33 AM
starting issues learjettech 2.9L & 3.0L V6 Tech 3 04-21-2009 06:42 PM
Charging / Starting issues... (forget the morning paper) sawred General Technical & Electrical 21 08-04-2006 08:48 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 01:42 PM.