horrible starting, revs up after starting. - Ranger-Forums - The Ultimate Ford Ranger Resource

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

horrible starting, revs up after starting.

Reply

 
 
 
  #1  
Old 06-26-2009
Member
Thread Starter
Join Date: Jun 2009
Location: Somonauk, IL
Posts: 4
horrible starting, revs up after starting.

I have a buddy with a real gem. Its a 96 4cyl ranger 2wd with a 5 speed.......and 265K miles Any time when going to start it, warm or cold, it just turns over and sputters like it wants to start then finally will after like 10-15seconds of cranking. Also, on select occasions (prolly 2 out of 5 starts) the truck will rev up to about 3 or 4K RPM. What could this be causing the starting issue? plugs or wires? fuel filter? fuel pump? relay? just trying to help my buddy make this thing last as long as possible.
 
Reply With Quote
  #2  
Old 06-26-2009
carbuff1991's Avatar
Member
Join Date: Sep 2008
Location: Watertown NY
Posts: 69
check the Idle Air Control valve and the Throttle Position Sensor.
 
Reply With Quote
  #3  
Old 08-12-2009
Member
Join Date: Mar 2009
Location: Poop, MA
Posts: 2
that can also be caused by the Mass air flow sensor.
 
Reply With Quote
  #4  
Old 08-12-2009
pwrranger88's Avatar
Member
iTrader: (1)
Join Date: Dec 2008
Location: West Greenwich RI
Posts: 330
it could be a leaking vacuum line
 
Reply With Quote
  #5  
Old 08-12-2009
David N's Avatar
Member
Join Date: Dec 2008
Location: Williamston, NC
Posts: 1,060
All of those. Mainly Idle Air Control. Or the map sensor.
 
Reply With Quote
  #6  
Old 09-01-2009
Join Date: Aug 2009
Location: Memphis
Posts: 157
Originally Posted by carbuff1991 View Post
check the Idle Air Control valve and the Throttle Position Sensor.
+1
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JASONGR81
General Technical & Electrical
16
08-04-2016 05:38 PM
daranger101
2.9L & 3.0L V6 Tech
21
09-14-2010 10:09 PM
Tys 4x4 FTW
General Ford Ranger Discussion
1
06-10-2010 11:39 AM
sickranger3.0
2.9L & 3.0L V6 Tech
17
11-25-2009 11:34 AM
i_luv_strats
Wheels & Tires Semi-Tech
3
03-05-2008 03:13 PM


Thread Tools
Search this Thread
Quick Reply: horrible starting, revs up after starting.


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.