The "What did you do to your Ranger today" thread - Page 115 - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums General Forum Arrow General Ford Ranger Discussion

General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #2851  
Old 10-06-2011
XLdriver4.0's Avatar
Member
 
I am: Brent B
Join Date: Sep 2011
Location: Yarmouth,NS
Vehicle: 09 Ford Ranger
Posts: 1
Total Props: 0
Drove it to work on what is the first true day of fall we've had yet, just +3 deg C this morning. chilly.
Reply With Quote
+ 0 -
  #2852  
Old 10-06-2011
98_ranger's Avatar
Member
 
I am: Josh Frazier
Join Date: Sep 2011
Location: Columbia,SC
Vehicle: 1998 Ford Ranger xlt
Drive Type: 2wd
Engine: 2.5
Posts: 180
Total Props: 0
http://www.ranger-forums.com/showthr...31#post1895431
Quote:
Post a new thread about it and give us some details man. theres a bunch of Mechanics here and i'm sure we can put heads together.
Reply With Quote
+ 0 -
  #2853  
Old 10-06-2011
98_ranger's Avatar
Member
 
I am: Josh Frazier
Join Date: Sep 2011
Location: Columbia,SC
Vehicle: 1998 Ford Ranger xlt
Drive Type: 2wd
Engine: 2.5
Posts: 180
Total Props: 0
Quote:
Is it turning over? or the starter wont even kick?
It will turn over but it wont stay started...
http://www.ranger-forums.com/showthr...31#post1895431
this explains it all ^^
Reply With Quote
+ 0 -
  #2854  
Old 10-06-2011
kanuck15's Avatar
Member
 
I am: Joe
Join Date: Mar 2011
Location: Pennsylvania
Vehicle: 1998 Ranger
Drive Type: 4x4
Engine: 5.0
Posts: 844
Total Props: 2
dead link?
Reply With Quote
+ 0 -
  #2855  
Old 10-06-2011
Member
 
I am: Chandler Eash
Join Date: Mar 2011
Location: Mount vernon, Ohio
Vehicle: 1998, ford , ranger
Posts: 21
Total Props: 0
Got my rugged ridge manual hubs in and installed them, got myself a 4x4 truck :)
Reply With Quote
+ 0 -
  #2856  
Old 10-06-2011
PAShooter's Avatar
Member
 
I am: Collin p
Join Date: Jul 2010
Location: Altoona, PA
Vehicle: 2000 Ford Ranger
Posts: 908
Total Props: 1
Washed her for my date on sat, and fixed one of the flares. Still need to get 2 for the back.
Reply With Quote
+ 0 -
  #2857  
Old 10-06-2011
Masteratarms93's Avatar
Member
iTrader: (8)
 
I am: Kevin Cline
Join Date: Mar 2010
Location: Goose Creek SC
Vehicle: 2010 Toyota Tacoma
Drive Type: 4x4
Engine: 4.0
Posts: 4,685
Total Props: 4
Got my MOOGs uppers and lower and UCAs installed.

Removed some more mud from the trip. A lot more lol.

Yesterday I put new shift bushings in and my new malfunction switch which is the blinker stalk assembly. The day before that I did the tranny fluid because it got really contaminated from the offroad excursion.

I found out I have a bad seal on the trans extension housing though so thats a new task. And I plan on doing my power steering fluid sometime soon.

I'm loving this time off. Finally getting some projects done :)
Reply With Quote
+ 0 -
  #2858  
Old 10-07-2011
98_ranger's Avatar
Member
 
I am: Josh Frazier
Join Date: Sep 2011
Location: Columbia,SC
Vehicle: 1998 Ford Ranger xlt
Drive Type: 2wd
Engine: 2.5
Posts: 180
Total Props: 0
Quote:
dead link?
use the first one
Reply With Quote
+ 0 -
  #2859  
Old 10-07-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
I am: Dave k
Join Date: Jul 2010
Location: RI
Vehicle: 2003 Toyota Taco TRD
Posts: 5,030
Total Props: -109
Quote:
Originally Posted by Masteratarms93 View Post
Got my MOOGs uppers and lower and UCAs installed.

Removed some more mud from the trip. A lot more lol.

Yesterday I put new shift bushings in and my new malfunction switch which is the blinker stalk assembly. The day before that I did the tranny fluid because it got really contaminated from the offroad excursion.

I found out I have a bad seal on the trans extension housing though so thats a new task. And I plan on doing my power steering fluid sometime soon.

I'm loving this time off. Finally getting some projects done :)
see what mud does
Reply With Quote
+ 0 -
  #2860  
Old 10-07-2011
Member
 
I am: ryan michael
Join Date: Aug 2011
Location: henderson nv
Vehicle: 2001 Ford Ranger
Posts: 33
Total Props: -2
went from broken to solid!!!! frame broken upper controll arm mount!!

http://www.facebook.com/home.php#!/p...type=1&theater


....



http://www.facebook.com/home.php#!/p...type=1&theater
Reply With Quote
+ 0 -
  #2861  
Old 10-07-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
I am: Dave k
Join Date: Jul 2010
Location: RI
Vehicle: 2003 Toyota Taco TRD
Posts: 5,030
Total Props: -109
stripped my fvcking o2 sensor now idk how im going to get it out
Reply With Quote
+ 0 -
  #2862  
Old 10-07-2011
FULLSCALE's Avatar
Level III Supporter

iTrader: (12)
 
I am: Adam L.
Join Date: Mar 2009
Location: Clinton, Ontario
Vehicle: 2007
Posts: 8,181
Total Props: 19
Haven't even seen mine in a week...
Reply With Quote
+ 0 -
  #2863  
Old 10-08-2011
Member
 
I am: RJ G
Join Date: May 2009
Location: Hazleton, PA
Vehicle: 2002 Ford Ranger XLT FX4
Posts: 216
Total Props: -2
Quote:
Originally Posted by 04RangerDave View Post
stripped my fvcking o2 sensor now idk how im going to get it out
Blue Wrench (acetylene torch). Works for me every time.

Heat it until it it's cherry red, then firmly grasp with vice grips and it should break free with a good hard twist.
Reply With Quote
+ 0 -
  #2864  
Old 10-08-2011
djfllmn's Avatar
Moderator
 
I am: DJ Fillman
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
Total Props: -4
gonna wax mine in a couple hours
Reply With Quote
+ 0 -
  #2865  
Old 10-08-2011
Member
 
I am: john cherry
Join Date: Oct 2011
Location: waterman, il
Vehicle: 1995 Ford Ranger
Posts: 3
Total Props: 0
started to change the front shocks and proceded to snap off the lower shock mount(facepalm)fixed and back on the road
Reply With Quote
+ 0 -
  #2866  
Old 10-08-2011
Member
 
I am: joe priest
Join Date: Sep 2011
Location: HULL
Vehicle: 2007 Ford Ranger STX
Posts: 139
Total Props: 0
i didnt do it today but i finally got the call that my wheels had come in so i went and got them and my new tires put on the truck yesterday. im lovin the new look. i bought some 18" TSW Jarama wheels and stuffed them into 235/50ZR18 continental extreme contact DSW tires.

Reply With Quote
+ 0 -
  #2867  
Old 10-08-2011
PAShooter's Avatar
Member
 
I am: Collin p
Join Date: Jul 2010
Location: Altoona, PA
Vehicle: 2000 Ford Ranger
Posts: 908
Total Props: 1
Fixed my tailgate rust problem, doors tomorrow and bedlining from the body line down
Reply With Quote
+ 0 -
  #2868  
Old 10-08-2011
Taylor's Avatar
Ive been dubbed....an old volk
iTrader: (18)
 
I am: not ashamed of the gospel
Join Date: Mar 2010
Location: Nashville, NC
Vehicle: 2004
Posts: 7,110
Total Props: 26
Today, I put more bedliner in places that yall wouldnt.

Pics tomorrow
Reply With Quote
+ 0 -
  #2869  
Old 10-09-2011
FULLSCALE's Avatar
Level III Supporter

iTrader: (12)
 
I am: Adam L.
Join Date: Mar 2009
Location: Clinton, Ontario
Vehicle: 2007
Posts: 8,181
Total Props: 19
Finally picked up truck up after my dad had it for a week... even got 25mpg on the trip home!
Reply With Quote
+ 0 -
  #2870  
Old 10-09-2011
djfllmn's Avatar
Moderator
 
I am: DJ Fillman
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
Total Props: -4
tbar crank and shackles
Reply With Quote
+ 0 -
  #2871  
Old 10-09-2011
Member
 
I am: sean m
Join Date: Sep 2011
Location: manchester nh
Vehicle: 1995 Ford Ranger
Posts: 46
Total Props: 0
thermostat and blower motor resistor and pigtail replacement
Reply With Quote
+ 0 -
  #2872  
Old 10-10-2011
Member
 
I am: joe priest
Join Date: Sep 2011
Location: HULL
Vehicle: 2007 Ford Ranger STX
Posts: 139
Total Props: 0
finally got the lil bottle of touchup paint ive been needing and covered up the rock chips and deepest scratches i could find
Reply With Quote
+ 0 -
  #2873  
Old 10-10-2011
Member
 
I am: RJ G
Join Date: May 2009
Location: Hazleton, PA
Vehicle: 2002 Ford Ranger XLT FX4
Posts: 216
Total Props: -2
Put the poor thing up on jackstands to attempt to find my clutch noise problem. Seems that something is loose between the bell housing and block.

Looks like I have some work to do...
Reply With Quote
+ 0 -
  #2874  
Old 10-11-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
I am: Dave k
Join Date: Jul 2010
Location: RI
Vehicle: 2003 Toyota Taco TRD
Posts: 5,030
Total Props: -109
Blinker Mod.
Reply With Quote
+ 0 -
  #2875  
Old 10-11-2011
Member
 
I am: joe priest
Join Date: Sep 2011
Location: HULL
Vehicle: 2007 Ford Ranger STX
Posts: 139
Total Props: 0
changed the oil, oil filter, plugs and wires. not sure when the plugs n wires were last done but its got a lot more get up and go now. it spins the tires nearly everytime i take off and gets a 2nd gear scratch almost as often
Reply With Quote
+ 0 -
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
The "What do you hate about your Ranger today" thread winks General Ford Ranger Discussion 172 09-12-2016 11:07 AM
The "What do you hate today about your Ranger" thread. dcrymes99ranger General Ford Ranger Discussion 32 10-08-2010 05:01 PM
"what did you do today....should be a category in the forums list dixie_boysles Ranger-Forums Office 6 05-26-2009 11:34 PM
For people with the "shorty" console.....where did you place you switches in/on it? lifted97ranger General Technical & Electrical 13 12-30-2007 11:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -6. The time now is 06:32 AM.