03 4.0 idle problem - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-09-2011
Member
Thread Starter
 
Join Date: Sep 2011
Location: ARLINGTON
Posts: 1
03 4.0 idle problem

hey i guys i got a 03 4.0 4x4 manual. its got 80k. and it starts fine then after a couple mins it

starts to shake and idles at like 300 then will start to shake pretty good. it runs fine on

freeway but as soon as i hit stop lights it sputters and wants to die on me. sometimes it will

run half power then kick in outta no where. [email protected] is fine and i ran a bottle of injecter cleaner

thru it and still does it. if ya guys know id much appreciate it.
Reply With Quote
  #2  
Old 09-14-2011
klc317's Avatar
Member
 
Join Date: Sep 2006
Location: Cincinnati, OH
Posts: 950
Is it showing a check engine light? Any codes?
Reply With Quote
  #3  
Old 09-14-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Did you re-oil the [email protected] just before it started doing this?
Reply With Quote
  #4  
Old 09-22-2011
Member
 
Join Date: Jan 2011
Location: Springfield, VA
Posts: 62
I had the exact same thing happen. It was my idle air control valve. It caused some suction problems that worked a couple hoses loose. Took $50 and an hour and a half to fix.
Reply With Quote
  #5  
Old 09-22-2011
98_ranger's Avatar
Member
 
Join Date: Sep 2011
Location: Columbia,SC
Posts: 180
i have sorta the same problem, but i have a 1998 ranger longbed 2wd, and mine will shake extremly bad, and wont stay on. it will idle for a good 5 seconds. then it cuts off. i have changed the sparkplugs, the fuel pump, the idle postioner sensor. and the fuel sensor. it will not throw codes.
not im at the point where i just want to dig a hole and push it in it.
some please help!!
Reply With Quote
  #6  
Old 09-22-2011
Member
 
Join Date: Jan 2011
Location: Springfield, VA
Posts: 62
Maybe you have a PCV tube come loose?
Reply With Quote
  #7  
Old 09-22-2011
98_ranger's Avatar
Member
 
Join Date: Sep 2011
Location: Columbia,SC
Posts: 180
ill check that when i get home, any more suggestions?
Reply With Quote
  #8  
Old 09-22-2011
Member
 
Join Date: Jan 2011
Location: Springfield, VA
Posts: 62
Without getting a fault code, I'm not sure. It sounds like an airflow issue, though.
Reply With Quote
  #9  
Old 09-22-2011
98_ranger's Avatar
Member
 
Join Date: Sep 2011
Location: Columbia,SC
Posts: 180
im getting fuel pressure but idk what is going on!!
Reply With Quote
  #10  
Old 09-23-2011
98_ranger's Avatar
Member
 
Join Date: Sep 2011
Location: Columbia,SC
Posts: 180
i clean the PCV tube. and it still wont run
Reply With Quote
  #11  
Old 10-06-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by 98_ranger View Post
i clean the PCV tube. and it still wont run
when you took your PCV off, did you hear something rattling around in it?
Also, What about your EGR? When you start it up, do you have the pedal to the floor to try and keep it running?
Reply With Quote
  #12  
Old 10-06-2011
Member
 
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Posts: 563
thats what mine would do until I found that mushed elbow I had to replace
Reply With Quote
  #13  
Old 10-07-2011
98_ranger's Avatar
Member
 
Join Date: Sep 2011
Location: Columbia,SC
Posts: 180
Quote:
when you took your PCV off, did you hear something rattling around in it?
no?
Quote:
When you start it up, do you have the pedal to the floor to try and keep it running?
tried, but it would still cut off
i'm about to take the bed off this weekend, i think that there is something loose in the tank, because when i changed the fuel pump the second time. i took the tank off. i though it would be easier.. but i was proven wrong
Reply With Quote
  #14  
Old 10-07-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
If the PCV didn't rattle replace it
Reply With Quote
  #15  
Old 10-07-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by 04RangerDave View Post
If the PCV didn't rattle replace it
x2. That may be your problem. your PCV should rattle like a snake.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 rough idle/slow return to idle whiskeybreath SOHC - 2.3L & 2.5L Lima Engines 1 11-27-2014 05:06 PM
low idle when slowing down to idle j_huhnke General Ford Ranger Discussion 13 04-06-2012 05:58 AM
High Idle / Low idle 2003 Ranger 3.0 thom2003 2.9L & 3.0L V6 Tech 1 03-27-2012 01:12 AM
low idle when slowing down to idle j_huhnke 4.0L OHV & SOHC V6 Tech 2 03-25-2012 10:26 AM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 12:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:02 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.