94 Ranger 3.0 No Crank/No Start - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-18-2016
Thread Starter

Member
 
I am: Timothy Trimmer
Join Date: Oct 2016
Location: Patterson
Vehicle: 1994 Ford Ranger XLT
Drive Type: 4x2
Engine: 3.0
Posts: 3
Total Props: 0
Icon13 94 Ranger 3.0 No Crank/No Start

Hi y'all! New to this site, wish I knew about this place a while back. Now, I got a problem that I at my wit's end with. At first when I would go to start my truck, it would just give a single click sound coming from my starter relay. I got me a new one and replaced it. But, being a dumbass, I didn't take off the terminal off the neg post and I zapped the hell out the the backside of the starter relay. Then it didn't click. I thought that the issue might have been the starter and/or solenoid so i took those over to the starter repair shop and they repaired it. Installed it and same issue. No crank, no start, no click. I'm thinking electrical. I looked at all my fuses and they all seemed good. I dont know about my relays but I don't think you need those for the ignition system, right? Is there an inline fuse or something that might have kicked the bucket because I got no clue about this anymore.
Reply With Quote
+ 0 -
  #2  
Old 10-18-2016
Member
 
I am: Jeff Martin
Join Date: Jul 2016
Location: BC Canada
Vehicle: 1999 Mazda B3000
Drive Type: 4x2
Engine: 3.0
Posts: 369
Total Props: 6
Check you fuses for continuity, a fuse can still be open even if it looks good.
Check your engine and battery ground, make sure they are tight and there is no corrosion.
Same for the positive side.
I don't know if there is a relay for the starter for 94.
Reply With Quote
+ 0 -
  #3  
Old 10-18-2016
Thread Starter

Member
 
I am: Timothy Trimmer
Join Date: Oct 2016
Location: Patterson
Vehicle: 1994 Ford Ranger XLT
Drive Type: 4x2
Engine: 3.0
Posts: 3
Total Props: 0
Thanks! Ill start testing tomorrow.
Reply With Quote
+ 0 -
  #4  
Old 10-19-2016
TheArcticWolf1911's Avatar
Member

 
I am: Cameron Howard
Join Date: Nov 2015
Location: Evansville, Indiana
Vehicle: 1999 Ford Ranger
Drive Type: 4x4
Engine: 3.0
Posts: 1,186
Total Props: 7
Check the battery and it's connections. Tighten them if necessary, clean off any and all corrosion. It's advisable to use either sand paper, a wire brush, or a battery terminal cleaner on these periodically. If they look fine and aren't corroded, then reassemble.

Also check the battery's voltage. It should be at about 12.6 volts. Generally if it's showing good voltage, then it's a good battery too. Although not always. It's worth having it checked at an auto parts store. They generally do this for free.

Do any lights come on when the key is turned on?
Reply With Quote
+ 0 -
  #5  
Old 10-19-2016
Thread Starter

Member
 
I am: Timothy Trimmer
Join Date: Oct 2016
Location: Patterson
Vehicle: 1994 Ford Ranger XLT
Drive Type: 4x2
Engine: 3.0
Posts: 3
Total Props: 0
Yes. All lights come on, radio, open door chime.
Reply With Quote
+ 0 -
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
95 ranger, 2.3, std, no crank no start issue cheetahman General Technical & Electrical 4 07-17-2014 10:26 AM
1988 2.3L Ranger won't start, only crank CLAARMAN SOHC - 2.3L & 2.5L Lima Engines 6 07-02-2014 08:23 PM
Won't crank/start! Please help! Brandon77 General Technical & Electrical 21 09-16-2009 04:37 PM
crank no start need help 4x4ranger 4.0L OHV & SOHC V6 Tech 0 06-13-2009 06:41 AM
Crank, crank, crank xXcecinestpasXx86 General Technical & Electrical 7 05-08-2009 11:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





All times are GMT -6. The time now is 07:43 AM.