Blinker malfunctioning - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 08-30-2014
Thread Starter

I am: Junior
Join Date: Aug 2014
Location: Houston, MO
Vehicle: 2014 Ranger
Drive Type: 4x2
Engine: 2.3
Posts: 1
Total Props: 0
Icon4 Blinker malfunctioning

Hello guys first time posting here, after days and days of searching I have found nothing.
1995 Ford Ranger 4x2, 5 speed 2.3L 4 cylinder with 8 sparkplugs.
Passenger blinker randomly flickers only while headlights are on and driving/accelerating down the road, doesn't happen while sitting there running. All lights work fine including the blinkers when there turned on. All fuses in the cab are good, I even tried pulling the blinker
fuse to see if that would make it stop, but it still does it. Any help on what could be causing
this problem would be greatly appreciated. Thanks.
Reply With Quote
+ 0 -
Old 08-31-2014
iTrader: (1)
I am: Ron Dean
Join Date: Jan 2014
Location: Vancouver, BC
Vehicle: 1994 Ford Ranger
Drive Type: 4x4
Engine: 4.0
Posts: 4,722
Total Props: 88
12vDC lights come on for two reasons, they have a Ground and they have power, thats the "normal" reason, lol.

Second reason is because another circuit(usually another light) is using that one light as a Ground.
When that happens power flows thru the light and it comes on.
(any one who has hooked up trailer lights has run into this, lol.)

In your case I would check the grounds on the Head lights and parking lights for good grounds.
The turn signal light itself is probably not the issue, the issue is that it has a good ground and another light doesn't.
Because of the flickering with movement I would suspect a loose ground wire, but there could be a 12volt headlight or parking light wire that has rubbed thru with the turn signal 12v wire which could cause the same symptom.

The turn signal bulb is your "test light", so if possible have someone watch that light while you move wires around to see if you can find a wiring location that causes the light to come on

Last edited by RonD; 08-31-2014 at 04:38 PM.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
Malfunctioning parking lever of ranger 96 ad74710 4.0L OHV & SOHC V6 Tech 4 05-30-2014 10:52 AM
Malfunctioning Turn Signals Z.Byers General Technical & Electrical 1 05-03-2013 05:53 PM
blower speeds malfunctioning blAckAnger General Technical & Electrical 17 08-06-2010 11:27 PM
windshield wipers and windows/dome light malfunctioning bfd's_ranger General Technical & Electrical 0 07-30-2010 10:07 PM
Blinker mod EdgedPike General Technical & Electrical 2 10-03-2004 03:25 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:12 AM.