No start / power, clicking relay - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Forum Arrow General Technical & Electrical

General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

LinkBack Thread Tools Search this Thread
Old 11-01-2013
Thread Starter

I am: Tiagz dsfs
Join Date: Nov 2013
Location: Canada
Vehicle: 1998 Ford EDGE RANGE
Drive Type: 4x2
Engine: 2.5
Posts: 1
Total Props: 0
Icon11 No start / power, clicking relay

Hello everyone, I am new to these forums and seeking some experienced advice.

I appreciate any input you guys have, this is for my brothers ranger I am trying to fix for him it is a white 98 2.5L RWD Edge with a 5 speed manual and 134,xxx kilometers. Lowest km vehicle in our family!

It runs well and has so until last night.

The symptom is that as soon as the battery is connected all you get is a click click click click coming from behind the stereo. After removing the stereo and the dash I freaked out as I felt the clicking from the ECU. but later after unplugging the ecu found the clicking to be from a relay behind it. *Phew*.

So I unplugged the relay and the clicking is gone, but there is no power to any of the vehicle lights or anything in the cabin?. I am unsure what this relay is responsible for. And I am unsure if replacing it will have any benifit to the situation.

I have checked every fuse with my multimeter and all have 0.00 OHM resistance so they are not blown.

my brother bought a new battery and installed it when it died right after. But checking the battery shows 12.60 volts after sitting overnight in the wal mart parking lot so I don't believe that to be the issue.

Tomorrow I will be cleaning connection from the battery as far as I can trace as well as the grounds. this is really confusing me and I would like to help my brother out and fix this issue,

IF anyone has experienced something like this PLEASE chime in.!


Good to meet all of you
Reply With Quote
+ 0 -
Old 11-02-2013
I am: Adam Lexington
Join Date: Nov 2013
Location: Toronto
Vehicle: 2008 Ford Ranger
Drive Type: 4x2
Engine: 3.0
Posts: 4
Total Props: 0
Check your starter relay.

Also try a few wacks of a hammer on your starter.
Reply With Quote
+ 0 -
Old 11-03-2013
I am: john millican
Join Date: Nov 2013
Location: eastland, texas
Vehicle: 2000 ford ranger
Drive Type: 4x2
Engine: 2.5
Posts: 1
Total Props: 0
I'm having a related relay issue with my 2000 2.5L RWD Ranger, only mine concerns identifying the fuel pump relay. Is there any readily available resource to identify these relays. All my owners manual gives me is a list of fuse amperages and colors. Thanks for any help provided.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
no start issue/ battery saver relay clicking jcam General Technical & Electrical 4 04-28-2015 10:36 PM
new type of relay/fuse panel and heavy duty relay cheese_man General Technical & Electrical 1 07-18-2014 03:25 AM
clicking noise when trying to start wayne225 General Technical & Electrical 11 07-29-2013 12:51 AM
clicking sound at start up (video) b25_ken SOHC - 2.3L & 2.5L Lima Engines 5 09-13-2011 09:34 PM
Power windows & mirrors not working - clicking sound recy General Technical & Electrical 7 07-09-2011 04:33 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:08 PM.