2.3 no start - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 05-20-2016
Thread Starter

I am: Nathan
Join Date: May 2016
Location: Georgia
Vehicle: 1985 Ford Ranger
Drive Type: 4x2
Engine: 2.3
Posts: 1
Total Props: 0
2.3 no start

Hey folks, I have a 1985 2.3 fuel injected manual that I've been working on for quite some time but I need some help.
I have spark, the timing is set correctly, fuel is getting to the rail, but I don't know beyond that. I used a noid light to see if the fuel injectors were getting a pulse and the light did not light up. I did use the GM PFI light because the only ford light I can find with these sets is the ford TBI light, which doesn't fit. The PFI light fits perfectly though.
I went to the junkyard and picked up a computer from an 85 2.3 manual and now instead of just turning over like it did with the old computer, now when I press the gas it sounds like it wants to start but it won't. The noid light still does not light up.
I initially turned it over with the new computer without disconnecting and reconnecting the negative battery connection, not sure if that affected anything resetting or the truck recognizing a new computer, I have since done that.

Any suggestions? I'd love some feedback, the timing belt is fine, doesnt seem to be slipping.
I have noticed when I press the gas while turning it over the gas gauge drops, and if I take my foot off it will go back up. After I put in the new computer it would try to start while giving it gas but stop and only turn over when the gas gauge dropped even if I still pressed the gas, if I let the gauge go back up it would then try to start when I pressed the gas. Now it only tries to start the first time I press the gas once it starts turning over, after that it doesn't acknowledge I'm pressing the gas then continues to turn over.

Any help would be greatly appreciated!
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
only start on easy start kyde General Technical & Electrical 2 05-25-2014 05:17 AM
Incorrect jump start. Truck won't start now. Pilot General Technical & Electrical 3 10-27-2013 07:07 AM
Won't start, dome light dies when trying to start. Jerkstore General Technical & Electrical 4 10-02-2011 09:53 AM
Ranger hard start issue HELP COLD START 1994splash 2.9L & 3.0L V6 Tech 1 06-08-2011 04:27 PM
remote start helliboarder General Ford Ranger Discussion 8 11-26-2004 11:29 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:08 AM.