Help w/ my ignition problem. i need truck 2moro please - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.3L & 2.5L I4 Tech Arrow SOHC - 2.3L & 2.5L Lima Engines

SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

LinkBack Thread Tools Search this Thread
Old 01-20-2008
Thread Starter

I am: jorge r
Join Date: Jan 2008
Location: key west, fl
Vehicle: 1994 ford ranger
Posts: 1
Total Props: 0
Help w/ my ignition problem. i need truck 2moro please

Well i had a bad ignition module cuz i had a spout fault. truck ran fine just a little rough. i have a 93 mustang 2.3L which ran perfect and i switched over the module and the car had no more spark. put the old one back on and still no spark. wierd.... i put both modules on the mustang and mustang has no spark.

i thought i shorted the modules somehow so i bought a new one and still no spark.... i got compression, i got fuel, replaced both coils.

any fuses other than on panel? any ideas please im down two cars?

update: ko test comes to a 111(pass) and timing belt isnt the problem cuz both cars ran 10 minutes before.. checked eec power relay and switched with fuel pump relay and nothing still got fuel pressure but no spark..

Last edited by cubanfisher; 01-20-2008 at 11:11 PM.
Reply With Quote
+ 0 -
Old 01-21-2008
Rev's Avatar
Rev Rev is offline
Level I Supporter
I am: J J
Join Date: May 2005
Location: San Diego, CA
Vehicle: 2001 Ranger Edge
Posts: 1,179
Total Props: 18
Your description of problems is a little hard to follow. It would also help if you provided a little more info on your truck. Have you checked all fuses under hood? Are you getting power to the ICM, coil packs, and CPS with the ign on? Does the injectors power toggle during cranking (test light should blink on and off). Check the coils primary (5 ohm or less) and secondary resistance (13-15 K-ohms). Just throwing out some things to check.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.3 ignition problem redrider92 2.3L & 2.5L I4 Tech 1 07-06-2010 08:10 PM
1988 Ranger ignition cylinder problem godsey1 General Technical & Electrical 4 06-12-2010 02:22 PM
1990 2.3l ignition problem scoutsize SOHC - 2.3L & 2.5L Lima Engines 7 07-05-2009 01:28 PM
Ignition problem? jetmex 2.9L & 3.0L V6 Tech 4 05-24-2009 07:28 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 10:39 PM.