questions after bl - Ranger-Forums - The Ultimate Ford Ranger Resource


1" & 3" Body Lifts General discussion of body lifts for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-01-2009
sgalka91's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: schererville
Posts: 148
questions after bl

so i just finished my body lift and i took it around the block and noticed my abs light was on. Is this normal with bigger tires on it??

also after i shut it off i tried to restart it and my battery was dead. Is there anything i obvious i could have done during the bl that would make my alternator go out

one more thing. My im guessing my speedo is going to be off because of my bigger tires. is it going to tell me my speed it higher or lower then what im actually going
Reply With Quote
  #2  
Old 11-01-2009
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
1. It is not normal. You may have destroyed a sensor, or stretched a wire. Something along those lines.

2. Battery may have been dead due to being unhooked for so long. Battery's on it's way out possibly.

3. Speedo will read SLOWER than you are actually traveling. How much slower, depends on your stock tire size and your new tire size. Whatever the percentage difference is, will be the difference. This also effects your odometer too.
Reply With Quote
  #3  
Old 11-01-2009
sgalka91's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: schererville
Posts: 148
okay about the abs as long as i don't see any fluid on the ground should it be okay. and one more thing does anyone know where the ground strap on the firewall goes it broke off while i was removing it.
Reply With Quote
  #4  
Old 11-01-2009
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
Bolts to the back of your engine block then goes up and bolts onto your firewall. How'd you break it?
Reply With Quote
  #5  
Old 11-01-2009
Hanks Rangers's Avatar
Member
 
Join Date: Sep 2008
Location: Sandpoint, ID
Posts: 821
probably forgot it!
Reply With Quote
  #6  
Old 11-01-2009
sgalka91's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: schererville
Posts: 148
while i was unbolting it the wire kept turning with the bolt.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Just some updated shots of the 150. Check it out, Stock/After/After FoMoCoFiddy Snapshots 18 02-22-2010 01:16 PM
ford edge lift questions(NOOB questions) tacorunner87 Suspension Tech 13 06-07-2008 12:09 AM
Rear leaf questions/shackle questions thesoundmaster Suspension Tech 3 10-18-2007 10:30 PM
nerf bars after body lift...how to raise them? JSpence819 Exterior Semi-Tech 5 09-10-2004 07:23 AM
status after # of posts?? cow_boy104 Ranger-Forums Office 15 06-05-2004 12:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:48 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.