03 ranger down for the count - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-14-2010
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2010
Location: Moreno Valley CA
Posts: 46
03 ranger down for the count

Hey all Im Jose and Im new to the ranger world not to wrenching though.I just got my 03 ranger edge 2 weeks ago and last night it let me down I was driving home and all of a sudden it lost half its power and the check engine light started flashing so a got a code scanner and its telling me its misfired on cylinders 4 5 6 it only has 89,000 miles so this has me stumpped any inoput I would greatly appreciate
Reply With Quote
  #2  
Old 04-14-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Remove the multi-pin plug on the top of the coil pack and inspect it for any corrosion.
Spray some electrical contact cleaner in it and work the plug on and off a few times.
Reply With Quote
  #3  
Old 04-14-2010
texasfan1000's Avatar
Member
 
Join Date: Sep 2006
Location: Amarillo, TX
Posts: 629
mine did this but it was 2 faulty plug wires. another option for you to check out
Reply With Quote
  #4  
Old 04-14-2010
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Check plugs and wires. Then the coilpack
Reply With Quote
  #5  
Old 04-14-2010
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2010
Location: Moreno Valley CA
Posts: 46
it has new wires I installed them hours before it started losing power it ran fine right after I installed them the plugs are 2 weeks old I changed them when I got the truck they are the autolite double platinums thanks for all the suggestions
Reply With Quote
  #6  
Old 04-16-2010
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2010
Location: Moreno Valley CA
Posts: 46
after more troubleshooting I discovered that the left manifold was glowing red after the truck warmed up when I turn on the truck when its cool it has power after one or two mins it loses half its power and it starts to buck and sputter so Im focusing on the driver side head since it was pinging on that side I could hear it going up hill could it be a blocked cat ?

I forgot to add I tested it with a different coil pack and wires and there was no difference
Reply With Quote
  #7  
Old 04-16-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Get a fuel pressure tester and hook it up to the fuel rail.
Start the truck and run it for a minute.
Check the fuel pressure.
Shut off the truck and watch the pressure gauge.
If it drops immediately , you have one or more injectors stuck open.
That would cause a glowing manifold.
Reply With Quote
  #8  
Old 04-17-2010
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2010
Location: Moreno Valley CA
Posts: 46
fuel injectors checked out fine I was advise to do a compression test and it was good I'll believing now that it might be a clogged cat it runs perfectly fine for about two mins I drove it around the block and after two mins it was stuggling to stay on and it would rev over 2,000 rpm once I got home I was able to rev to 3,000 rpm when I wasnt in gear I'm really stumped on this .What are the symptoms of a clogged catalytic convertor
Reply With Quote
  #9  
Old 04-21-2010
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2010
Location: Moreno Valley CA
Posts: 46
UPDATE

The issue was the pre catalytic converter on the left side I "unplugged " it and put it back together and the truck has wayyyy more power since I bought it three weeks ago

Thanks for all the suggestions
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger Down! Ranger Down! kirbo7106 SOHC - 2.3L & 2.5L Lima Engines 11 01-06-2012 09:11 PM
Down Under, On Top, Down South :) Scrat01 Member Introductions 9 09-13-2010 08:14 AM
slowing down... down hills... does yours do this? nross General Ford Ranger Discussion 26 12-09-2009 01:25 PM
post count 04edge Ranger-Forums Office 21 03-24-2005 11:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:43 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.