1999 Ranger loses all power when turning key to start - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-08-2014
Member
Thread Starter
 
Join Date: Feb 2014
Location: Shoreview
Posts: 20
1999 Ranger loses all power when turning key to start

hey i have a issue that im not sure what it is.. i have a 1999 ranger 4x4 3.0l and yesterday it started just fine the first 4 times i started it but then suddenly i stop for gas and came back out and went to start it but as soon as i turned the ignition to start it just clicked once and all power was gone then nothing when i tried turning the key over. but i take the negative cable off the battery and mes with it for a sec and put it back on and all power is just fine again but does the same thing when i try to start it. happens over and over. i changed the oil a couple days prior and as stupid as it is the ooil filter is directly above the start and oil got all over it so i put in a new starter today and still same thing. my battery is good full charge. i would assume its a ground issue but figured id get more opinions on the issue. any ideas? thanks
Reply With Quote
  #2  
Old 04-09-2014
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
the negative battery cable is your problem

you bent the connector and restored a partial connection , time for a new negative cable
Reply With Quote
  #3  
Old 04-09-2014
Member
Thread Starter
 
Join Date: Feb 2014
Location: Shoreview
Posts: 20
the ground is what everyone says it is and first thing i figure it was also but i installed all new cables for ground and power and still have the issue. i even put a new starter in cause the one that was in it was covered in oil. how is the grounding suppose to be setup in this truck? battery - to chassis, chassis to engine... are there more connections for the ground?
Reply With Quote
  #4  
Old 04-09-2014
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
battery to engine -- engine to cabin -- cabin to frame

engine to cabin ground is a aluminum ground strap
Reply With Quote
  #5  
Old 04-10-2014
Member
Thread Starter
 
Join Date: Feb 2014
Location: Shoreview
Posts: 20
had a friend of mine who is a mechanic look at it and turned out it was not a ground issue but a positive cable causing the issue. works great now. thanks for the help
Reply With Quote
  #6  
Old 04-11-2014
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
i stand corrected

but at least the problem is solved
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Radio comes on when key is off 1999 Ramonsito Audio & Video Tech 1 11-06-2014 06:52 PM
87 ranger loses power when warm. bikrboi165 SOHC - 2.3L & 2.5L Lima Engines 0 12-03-2013 06:45 PM
Window motor loses power. hornedfrog1985 General Technical & Electrical 25 08-28-2010 12:05 PM
05 ranger wont start upon first turn of key?? fabioonachopper DOHC - 2.3L Duratec / Mazda L Engines 3 04-23-2010 09:20 AM
Truck loses power once put in gear.. evilclown312 2.9L & 3.0L V6 Tech 3 04-22-2010 08:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.