99 3.0 misfire ?? - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-16-2011
Member
Thread Starter
 
Join Date: Apr 2011
Location: Palestine, Ohio
Posts: 12
Icon5 99 3.0 misfire ??

A couple weeks ago as I was driving along my truck began to shake and lost power. No check engine light came on. I had ran some E85 the week before so I thought maybe that caused the problem. I changed the spark plugs and wires,fuel filter and also added some Lucas injector cleaner...no change. The next day the check engine light came on, so I went to have the parts store to have them check the code. They said it had a misfire on cylinder 6, and lean on bank 2. Can anyone tell me what would cause something like this to happen?? This truck didn't have much power to start with...now it has none. Any help or advice would be greatly appreciated.

Last edited by jscantland; 05-16-2011 at 03:43 PM.
Reply With Quote
  #2  
Old 05-16-2011
Member
Thread Starter
 
Join Date: Apr 2011
Location: Palestine, Ohio
Posts: 12
Just went to town and now the battery light is flashing. Now what is going on?? I was kinda thinking maybe a dirty or defective injector, but now I'm even more confused. SOMEONE PLEASE HELP ME!!!
Reply With Quote
  #3  
Old 05-17-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Try cleaning / checking all the ground connections. Someone posted a while back that a bad ground to the engine was causing a sporadic misfire .
The battery light flashing could also be a bad ground , the alternator failing , or the serpentine belt tensioner may be frozen and letting the belt slip.

eta
These trucks don't seem to like to run well on E85.
Reply With Quote
  #4  
Old 05-17-2011
Member
iTrader: (2)
 
Join Date: Mar 2011
Location: Bloomington, MN
Posts: 208
My truck runs great on E85, much better on corn than gasoline.

Check your injectors jscantland, if you have a VOM, disconnect the injector plug and check the resistance. Should be about 14-16ohms.
Reply With Quote
  #5  
Old 05-19-2011
Member
Thread Starter
 
Join Date: Apr 2011
Location: Palestine, Ohio
Posts: 12
Icon14 Figured it out

Couldn't take it anymore so I decided to buy the manual and tear into it. I tested the #6 injector and guess what...no resistance, all the others tested good. Replaced the bad injector and also the # 6 spark plug because it was already wasted. Now she runs like a champ, well, as good as a stock 3.slow can be expected to. The battery light isn't flickering anymore either. I just wanted to say thanks to you guys for your input.

Justin

Last edited by jscantland; 05-19-2011 at 08:09 PM.
Reply With Quote
  #6  
Old 07-11-2011
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
how did you test the injector?
Reply With Quote
  #7  
Old 07-11-2011
Member
iTrader: (2)
 
Join Date: Mar 2011
Location: Bloomington, MN
Posts: 208
Hook a lead to each prong to test resistance.
Reply With Quote
  #8  
Old 07-11-2011
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
is there a good how to that you know of that i can read to how to get and replace injectors?
Reply With Quote
  #9  
Old 07-12-2011
Member
Thread Starter
 
Join Date: Apr 2011
Location: Palestine, Ohio
Posts: 12
I bought the Haynes Manual. It tells you step by step how to do almost everything. If you have a little general mechanical knowledge, you can figure it out. Against my better judgement, I just went to Advance Auto Parts to get the injector. I'm thinking it was $55-60. I did see some cheaper on E-bay, but didn't want to wait on shipping and so on.
Reply With Quote
  #10  
Old 07-12-2011
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
yea thats the only reason i buy from advance. i look on other sites for the right part then go to advance, price match, and pick it up in store. shipping is annoying ha. but when you replace injectors, do you normally just do it one at a time, is it a regular maintenance practice? im saying should i replace mine? im sure they never have and my truck is reaching 200k.
Reply With Quote
  #11  
Old 07-12-2011
Member
Thread Starter
 
Join Date: Apr 2011
Location: Palestine, Ohio
Posts: 12
I just replaced one, and I am at just under 150k. I can't tell you if that is the best way to go about it, but that fixed my problem. It would be real easy to change them all while you have the upper intake off. If I'd have had the extra $$$ I would have probably replaced them all.
Reply With Quote
  #12  
Old 07-12-2011
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
basicaly, there right under the upper intake tho? sounds easy enough. thanks!!
Reply With Quote
  #13  
Old 07-12-2011
Member
iTrader: (2)
 
Join Date: Mar 2011
Location: Bloomington, MN
Posts: 208
You can get Motorcraft injectors through Rockauto for about $50.
Reply With Quote
  #14  
Old 07-12-2011
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
sweet thank you very much...got myself a good list of projects
Reply With Quote
  #15  
Old 07-12-2011
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
how many lbs/hour do i want??
Reply With Quote
  #16  
Old 07-13-2011
Member
Thread Starter
 
Join Date: Apr 2011
Location: Palestine, Ohio
Posts: 12
Quote:
Originally Posted by Kris03 View Post
basicaly, there right under the upper intake tho? sounds easy enough. thanks!!
Yes, once you remove upper intake you'll be able to access the fuel rails and injectors.
Reply With Quote
  #17  
Old 07-13-2011
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
sweet deal. thank you! and as for the lbs/hour? do you know what stock is?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
cylinder 4 misfire skankinandy SOHC - 2.3L & 2.5L Lima Engines 20 10-15-2015 03:26 AM
Misfire 4,5,6 help. JDRead 2.9L & 3.0L V6 Tech 10 09-24-2008 02:10 AM
help misfire after i washed engine? vic 2.9L & 3.0L V6 Tech 3 08-13-2006 01:37 PM
Engine misfire???? phatspeed7x 4.0L OHV & SOHC V6 Tech 4 07-02-2006 09:08 AM
Misfire TBarCYa 4.0L OHV & SOHC V6 Tech 5 02-23-2005 11:14 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.