99 Ranger Problems - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-24-2012
Member
Thread Starter
 
Join Date: Jun 2012
Location: Austin, Texas
Posts: 4
Icon9 99 Ranger Problems

Alright let me first start off by saying thank you in advance. Anyone's input will be greatly appreciated.

Let me first add that the only known problem with my truck is a minor oil leak (which I keep on top of)

I started my truck a week ago and noticed that when I would sit in idle the truck would shake a bit, I thought it was just my truck running out of gas due to the gas gauge malfunctioning. This is something Ive dealt with for awhile so I'm pretty used to it. I went ahead and bought some gas and the issue remained. I decided then I would check the oil. The oil was a little low about a quart so I replaced it. (The last complete oil change I had was about 1,500 miles ago.) When I started my truck back up it started to run fine. I ran it for the rest of the day.

The next morning I started it and the engine sounded like it was shaking. I popped the hood and could see it shaking. I had no choice but to leave where I was to a friends house up the street. (be leave me I didn't wanna drive it) About five miles down the road my hood started smoking. I managed to make it to my buddies house(where I am now.) and popped the hood. From what I saw it looked like my radiator was leaking out fluid all over my air filter. I turned my truck off and decided to surf the web to find a good forum site to research my issues on.
Thus I found RANGER FORUMS...

And so I decided not 15 minutes ago that I would try and explain my situation and even make a video to physically show you guys what I problem is. But when I went to start my truck it started acting normal.

When I first saw my truck acting this way I thought it was maybe a motor mount that needed replacement. Now seeing it act normal I don't think it is.

If anyone has any info please let me know what you think. Also if you have any questions for me I will be happy to answer them for you to better help me.

Thank,
Conspicuous
Reply With Quote
  #2  
Old 06-24-2012
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
I'm assuming it was Anti-freeze that was spilling out?
Where was it from exactly?
Reply With Quote
  #3  
Old 06-24-2012
Member
Thread Starter
 
Join Date: Jun 2012
Location: Austin, Texas
Posts: 4
Quote:
Originally Posted by StxDangerRanger View Post
I'm assuming it was Anti-freeze that was spilling out?
Where was it from exactly?
Yes sir is was.
I'm not sure exactly where it was spilling out at. When I went to look i was everywhere and wasn't spilling anymore. I realize I more then likely have a leak that needs repair. But would that make my engine act the way it did? I did just fill the radiator up cause it was low. I forgot to mention that.
Reply With Quote
  #4  
Old 06-24-2012
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
the engine was shaking while the antifreeze was spilling out, correct?

Also, What year truck is it, and what Engine. that will help a bit.
Reply With Quote
  #5  
Old 06-24-2012
Member
Thread Starter
 
Join Date: Jun 2012
Location: Austin, Texas
Posts: 4
Quote:
Originally Posted by StxDangerRanger View Post
the engine was shaking while the antifreeze was spilling out, correct?

Also, What year truck is it, and what Engine. that will help a bit.
Yes the engine was shaking while the anti-freeze was spilling out.
Its a 1999 Ranger 3.0
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 07:35 AM
Got My Ranger Back from the Accident.. MORE PROBLEMS! disaster123456 4.0L OHV & SOHC V6 Tech 6 11-05-2007 11:38 AM
5 Problems With My Ranger. Need Help. Dosh142 General Ford Ranger Discussion 7 12-02-2006 09:58 AM
1996 Ford Ranger 2.3L Automatic transmission problems USMCWHITENER Drivetrain Tech 0 11-23-2006 10:57 PM
Problems with New Ranger 05EDGESCAB 2.9L & 3.0L V6 Tech 11 07-22-2005 10:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:29 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.