bad idle problem - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-10-2005
mcerwing's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: hesperia, ca
Posts: 171
bad idle problem

I have an 89 ranger 2.9 L 2WD ext cab. My truck started acting up on me the other day. I was driving around like I normally would and when I came to a stop, my truck was idling around the 2500 rpm range. My gas pedal wasn't stuck, and i wasn't running the a/c or anything. And it only does this when it wants to. It happened 4 times yesterday and once this morning. Does anyone know what is wrong with it????
Reply With Quote
  #2  
Old 09-10-2005
marcos's Avatar
Member
 
Join Date: Aug 2005
Location: hesperia, California
Posts: 492
Dont worry mike my truck does the same thing sometimes and i dont know why it does it either except my truck will idle at 2000 not as high as yours....

so we are bothe in the same state....
Reply With Quote
  #3  
Old 09-10-2005
mcerwing's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: hesperia, ca
Posts: 171
I still want it fixed though
Reply With Quote
  #4  
Old 09-11-2005
marcos's Avatar
Member
 
Join Date: Aug 2005
Location: hesperia, California
Posts: 492
yeah dont worry my dad tole what you could do so i just gotta give you your money and you can get that s*** fixed... btw your truck is better than myne....
Reply With Quote
  #5  
Old 09-11-2005
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
sounds like the idle air sensor
Reply With Quote
  #6  
Old 09-12-2005
mcerwing's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: hesperia, ca
Posts: 171
well yesterday it stopped the rpm "hanging", but when it idled it was only around 300 rpm. so i went to autozone and had them test my throttle positioning sensor. they found it was bad and so i replaced it and my truck seems to be running fine. would the tps also have caused the high rpm hanging, or is this another thing that needs to be fixed? It's not doing it right now, but i don't want to be off-roading and have this problem pop up again.
Reply With Quote
  #7  
Old 09-12-2005
a311fanam's Avatar
Member
 
Join Date: Dec 2004
Location: Westerly, RI
Posts: 2,006
Its the throttle body! Spray the cable with some wd-40, and floor it a couple times
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Stupid bad stutter problem, idle rough, please help!!! TexMex 4.0L OHV & SOHC V6 Tech 4 10-03-2013 08:01 PM
Bad Idle Problem Fished 2.9L & 3.0L V6 Tech 1 05-17-2013 11:06 AM
The_Dealer: Bad Deal Bad Member Bad Sell! LayingFrame89 Ranger Products, Company, & Member Reviews 34 12-01-2007 07:59 AM
Stock Drivesaft with RCD = BAD BAD BAD PICS INSIDE ranger General Ford Ranger Discussion 32 07-31-2007 12:50 PM
ALL offroaders are BAD BAD BAD! FMD General Ford Ranger Discussion 13 04-25-2006 08:21 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:23 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.