Engine is being weird help. - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-23-2010
Member
Thread Starter
 
Join Date: Nov 2010
Location: CA
Posts: 44
Engine is being weird help.

What's up everyone-

So, I have this problem with my engine... I go to start my truck(2001 ford ranger 3.0 auto) and it takes a second to start then it idols really violently(kind of shakes) then the idoling slowly gets less powerful and then it shuts off. I go to restart it and give it some gas when I turn the key and it starts up and I give it some gas and runs fine... What's the problem? I just recently(last month) had the heads replaced and the engine and fluids completly tuned up (or so I thought). From what I've read on here it might be a vacume leak?

Thanks-ETHEN-
Reply With Quote
  #2  
Old 12-23-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
First off , get the codes read .Then post them here .
Your issue could be a faulty fuel pump and/or filter.
Reply With Quote
  #3  
Old 12-23-2010
Member
Thread Starter
 
Join Date: Nov 2010
Location: CA
Posts: 44
Quote:
Originally Posted by OTRtech View Post
First off , get the codes read .Then post them here .
Your issue could be a faulty fuel pump and/or filter.
The check engine light didn't pop up. Will it still have codes?
Reply With Quote
  #4  
Old 12-23-2010
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
if no light, no codes.
what about your injectors? how did those look? when was the last time you changed your fuel filter? does your gas gauge work (could be a sign of fuel pump not working)? i'm sure if you got it tuned up, im sure there are new plugs in it. but you could check those. or even plug wires. just simple stuff first.
Reply With Quote
  #5  
Old 12-25-2010
Member
 
Join Date: Oct 2010
Location: manilla ontario
Posts: 11
could be a sticky iac (idle air control valve) they have a tendency to stick and then it causes a VERY rough idle and can make it stall. pull it off, 2 bolts on top of your throttle body. spray it with wd40 or whatever you got, shake it out and put it back on. i have had it happen on 3 different ranger with different motors. thats why when you give it gas opening the butterfly it runs ok. by the way a sticky iac wont throw a code or light
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Weird Engine Humming, Attached Video Clip w/ Sound olsonk_89 General Ford Ranger Discussion 15 06-25-2006 07:57 PM
Engine swap is being set in motion... SONICEDGE03 8-Cylinder Tech 15 04-11-2006 06:04 PM
Help: weird sound coming from engine compartment winks General Technical & Electrical 12 12-07-2005 11:49 AM
Weird sounds from engine compartment, help? winks General Technical & Electrical 12 11-17-2005 09:36 AM
weird engine idle CAW General Ford Ranger Discussion 17 09-28-2005 07:54 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.