Engine Upgrades? - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 01-13-2012
Member
 
Join Date: Jan 2012
Location: scranton pa
Posts: 11
I have the same motor and I had a cel ( check engine light) but it was on for an evap problem so I really never checked up on it. I was averaging 10 mpg!!!! I thought to myself that its got to be something more than an evap code. When I scanned it my scanner said that both my o2 sensors were shot. I replaced them and now I'm getting average about 14-17 mpg. Just a little something but it worked for me. Good luck
Reply With Quote
  #27  
Old 01-13-2012
Member
 
Join Date: Jan 2012
Location: schenectady
Posts: 44
due to your serious lake of milage i am concerned with your injectors/ sensors o2 sensors will rob you of power/ milage and wont thow a code usualy on obd1 there cheap and easy next thing is clean the maf and run sea foam though it both intake and gas after that... you got a lead foot lol
Reply With Quote
  #28  
Old 01-14-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
how do i check the injectors last fall i ran system cleaner threw it didnt help. i unpluggled the MAF and it felt like i had a lil more power but i just drove it around the parkent lot not really a good test. and the roughness of it could of gave me false fell of power at teh speed. any way to check the O2 i got got scanner i didnt get any of those codes like u said. is there any way to check. when cleaning the maf do i have to take it completly out becasue i dont have the security style bits. can i just spray in the hole. like i said in an early post my buddy had a 2000 ranger manual he got like 15 to 18 i believe he said his truck hit 100( he had a chip but does it make that much of a diff) easy and mine barrly hits 65. idk what is conciders lead foot with this truck lol. u after to put it to the floor to get anythign out of it to just keep up with normal trafic flow
Reply With Quote
  #29  
Old 01-14-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
iv had few ppl comment about tire size. i got 235 or 245 not sure on 15 rims. there called winter force tires. i dont think there much bigger then a stock tire but they shouldnt have that much effect should they
Reply With Quote
  #30  
Old 01-14-2012
Member
 
Join Date: Dec 2011
Location: Rosedale, WV
Posts: 215
no. they shouldn't affect your power that much... even with my 2.0 i don't quite need to run it that hard to keep up with traffic... try plugs, wires, coil packs, o2 sensors, complete fluid change... check tire pressure and such... there's no reason you should have that little power...
Reply With Quote
  #31  
Old 01-14-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
i did spark plugs and wires when i first got the truck they were stock and pretty much melted. after i put new ones in she started to squat on acc. i have changed oil but thats it. tires i check a few weeks ago this cold temp change might affect it a lil but not over the whole time i had her. idk if clutch would effect much its wearing prob time for a new one but it dont slip or anything just feels weird every now and then
Reply With Quote
  #32  
Old 01-14-2012
Member
 
Join Date: Dec 2011
Location: Rosedale, WV
Posts: 215
check o2 sensors? coil packs? put a scanner on it? pull any codes with it?
Reply With Quote
  #33  
Old 01-14-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
98 doesnt have coil packs? havent checked the sensor yet idk how if there is a cut and dry way of doign it. i do got a scanner. i got the system to lean code. P 0171 or something like that cant remeber if it was bank 1 or 2 guess ill have to wait till my light comes on again.
Reply With Quote
  #34  
Old 01-14-2012
Member
 
Join Date: Dec 2011
Location: Rosedale, WV
Posts: 215
check the sensors... if the engine thinks it's constantly too lean, then it will constantly dump fuel into itself, running "pig rich" instead... costing you fuel mileage and power in a major way...
Reply With Quote
  #35  
Old 01-14-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
that makes lots of sence. is the MAF or o2 that controls that or both. i do no that my MAF is most likly dirty since i use a [email protected] do u no a way of cleaning it with out taking it out completly i dont have the securty style bits i jsut got regular torx
Reply With Quote
  #36  
Old 01-14-2012
Member
 
Join Date: Dec 2011
Location: Rosedale, WV
Posts: 215
it's a combination of both that ultimately controls fuel... but the engine gets its "lean code" from the o2 sensors... if they show lean the engine will inject more fuel... and a dirty MAF will contribute to this... i don't know how to clean it however... you might try using a small flat head screwdriver on the security bits... had them in my playstation3, that trick got the security bit screws out, then i replaced them with phillips...
Reply With Quote
  #37  
Old 01-14-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
do u no how to check the o2 sensor is it buy a new one put it in and find out if it helped or not.
Reply With Quote
  #38  
Old 01-14-2012
Member
 
Join Date: Dec 2011
Location: Rosedale, WV
Posts: 215
that's how i would... the game i'm an expert at: Part Dart...lol... with the 3.0, there should be two... keep in mind i drive a ranger with the 2.0 four cylinder... it's carbureted and has no sensors or ECU equipment to speak of... and even if it doesn't help completely, it will help diagnose the true problem...
Reply With Quote
  #39  
Old 01-14-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
ya i wish mine was carburated. i no how they work dealing with 4wheelers alot lol these computer operated things not a clue lol
Reply With Quote
  #40  
Old 01-14-2012
Member
 
Join Date: Dec 2011
Location: Rosedale, WV
Posts: 215
it's simpler, yet STILL a PITA!! honestly i wish i had EFI... with the carb i gotta deal with stuff like the choke not opening, and the carb needing rebuilt, and such... plus you can go turbo with EFI waaay easier than you can do a blow through turbo carb...
Reply With Quote
  #41  
Old 01-14-2012
Member
 
Join Date: Jan 2012
Location: schenectady
Posts: 44
Sooo true. If your really interested in checking the the sensors operation then get a haynes manual o2 sensors need replacing every 75k
Reply With Quote
  #42  
Old 01-15-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
oh well as far as i no there factory sensors and i got 125k on her. i do got a haynes manual has already come in hand for me lol
Reply With Quote
  #43  
Old 01-15-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
i unplugged the maf and she got a boost. she still has crappy top end but i made it to 80 and still was slowly going up but i had to slow down lol. she had more power she never pushed me back in teh seat b4. i think this whole prob was my maf. tm im gonna clean it and try and in the near futre change my o2 sensors
Reply With Quote
  #44  
Old 01-16-2012
Rottn35's Avatar
Member
 
Join Date: Jul 2011
Location: Livingston,Tennessee
Posts: 17
I have a 93 3.0 with 5 spd but mine is 2wd and I get 22 running 80 and still have plenty of power. I have a bed cover and the first things i did when I got it was change the o2s and cleaned mass airflow sens then got some sea foam spary and cleaned the intake out. gained power and mpgs went from 16 to 20 gained a little more when I put on the bed cover
Reply With Quote
  #45  
Old 01-16-2012
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Quote:
Originally Posted by myersth View Post
oh ya i havent stated that she barrly holds 65. u have to mash it in 4th and 5th just to hold 65 in the high way
why do u need to go any faster? I'm lucky if i even hit 65
Reply With Quote
  #46  
Old 01-19-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
Quote:
Originally Posted by 04RangerDave View Post
why do u need to go any faster? I'm lucky if i even hit 65
cause the road i drive anyday has a speed limit of 65 and everone goes like 80
Reply With Quote
  #47  
Old 01-19-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
i cleaned my maf and shes got a lil kick to her now. shell hit 80 and still want more but she accelerates slowly after 70 but its goes up when she would stop at 60 and have to push for anything more. she doesnt seem to run as hard now. she sifts more smooth. shell run 65 at about 2500 when b4 ud have to be if 4th running her up to 3 grand to get 60 and be able to get into 5th now everything is a smooth relaxed increase. now i just got to wait for my next fill up see if i got more mpg but in my theroy of how shes running it should increase and in spring when it warms up imma change her 0s senseors just because i beleve there oringal and shes got 125k on her id like to thank every one for helping and giving there opions
Reply With Quote
  #48  
Old 01-21-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
I have the same issue in my 2001 ranger 4c4 man
Reply With Quote
  #49  
Old 01-21-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
You say clean your maf what is that??
Reply With Quote
  #50  
Old 01-21-2012
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
It measures how much air is going into ur motor. Its right after the air filter and it has a plug that goes into it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
08 ranger 4.0l engine upgrades? foxmotoryder 4.0L OHV & SOHC V6 Tech 4 10-17-2011 10:20 AM
looking for some engine upgrades yellow rhino 2.9L & 3.0L V6 Tech 10 07-07-2010 08:57 PM
upgrades for engine? sideswipe 4.0L OHV & SOHC V6 Tech 12 10-06-2008 09:03 PM
cheap flex upgrades and chevy spring swap?'s gumby Suspension Tech 29 09-05-2006 08:36 PM
Jusnes Factory Upgrades blackrainja08 Exterior Semi-Tech 14 09-05-2006 04:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.