Engine Upgrades? - Page 3 - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #51  
Old 01-22-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
The mass air flow sensor? I thought if you unplugged itit would mess up the engine
Reply With Quote
  #52  
Old 01-22-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
no its like a by pass to find out if ur sensor is fine or not. I unplugged mine it ran rough for a awhile( i dnt think the comuter relized instantly right a way it was unplugged because my CEL didnt pop on for a lil while) but once it did she ran the best she ever has. Then i cleaned it plugged it back in and it runs almost as good as it did unplugged
Reply With Quote
  #53  
Old 01-22-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
Alright well I had it cleaned when I first got it how often does it need to be done?
Reply With Quote
  #54  
Old 01-22-2012
Member
 
Join Date: Jan 2012
Location: schenectady
Posts: 44
depends on how much crap is going through your intake do you do any off roading?
Reply With Quote
  #55  
Old 01-22-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
I play in the mud overt now and again nothing serious man
Reply With Quote
  #56  
Old 01-23-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
I unplugged my maf and it shifted so hard dang near gave me whiplash should it do that?
Reply With Quote
  #57  
Old 01-25-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
mine was like that till the check engine light came on and it had time to relize that it didnt have a sensor any more then it got smoother
Reply With Quote
  #58  
Old 01-26-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
The check engine light was on while It was doing it how long did it take to smooth out
Reply With Quote
  #59  
Old 01-28-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
like 2 or 3 times of driving it unplugged. but itss offical i went from 12 to 15 mpg just by cleaning it.
Reply With Quote
  #60  
Old 01-28-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
Alright I'll try that
Reply With Quote
  #61  
Old 01-30-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
I just filled up yesterday and I have 42 miles to a qaurter of a tank is that good?
Reply With Quote
  #62  
Old 01-30-2012
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
Um i didnt read the past few few posts (on my phone) so i dnt kno wat mods u have but id say no thats not too good. I get somewhere between 60 and 70 to a quarter.
Reply With Quote
  #63  
Old 01-30-2012
2006crfrider's Avatar
Member
 
Join Date: Apr 2011
Location: Spokane,WA
Posts: 424
Quote:
Originally Posted by Kris03 View Post
Um i didnt read the past few few posts (on my phone) so i dnt kno wat mods u have but id say no thats not too good. I get somewhere between 60 and 70 to a quarter.
That's about what i get and I'm running 31 inch tires.
Reply With Quote
  #64  
Old 01-30-2012
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
im gunna take a shot in the dark but id guess if your driving style contiued to empty tank...id guess around 13mpg.
Reply With Quote
  #65  
Old 01-31-2012
myersth's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: scottdale,pa
Posts: 101
i get from 14 to 15 since cleaning my MAF and when its gets nice out imma check/replace my o2 sensors
Reply With Quote
  #66  
Old 02-03-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
Ok so I cleaned my maf new fuel filter new spark plug wires and changed oil and filled up with sea foam I have 30 miles on the odometer and a lil above 3/4s of a tank left, I now this isn't good. And that because I have been driving like a grandma
Reply With Quote
  #67  
Old 02-03-2012
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
Did u get gas from same gas station?
Reply With Quote
  #68  
Old 02-03-2012
Member
 
Join Date: Nov 2011
Location: Levelland
Posts: 34
No went to the cheaper one whys that?
Reply With Quote
  #69  
Old 02-26-2012
Member
 
Join Date: Apr 2011
Location: apopka, fl
Posts: 173
3.0L being slow? what the ....

Quote:
Originally Posted by myersth View Post
oh ya i havent stated that she barrly holds 65. u have to mash it in 4th and 5th just to hold 65 in the high way
im not sure what yall are talking about...all yall are talking about here....

my best friend owns a 1987 F150 with the 302.... i cant beat him but i keep up with him in 1st gear but he pulls away in 2nd and 3rd.

my other friend has 1997 f150 with the 4.6 mustang motor... i beat him everytime!!!

this whole thing of the 3.0L only doing 90 down hill..... ive had my ranger up to 132mph and getting 16mpg doing so..... this is according to the gps....
im looking to make my ranger faster just so i can beat my friend's 1987
Reply With Quote
  #70  
Old 02-26-2012
Member
 
Join Date: Apr 2011
Location: apopka, fl
Posts: 173
the 132 is on level road it does around 120 up hill and around 140 to 150 downhill depending on how long downhill is
Reply With Quote
  #71  
Old 02-26-2012
2006crfrider's Avatar
Member
 
Join Date: Apr 2011
Location: Spokane,WA
Posts: 424
Some how i doubt you have hit 130. The Governor would have already kicked in and cut fuel to the engine.
Reply With Quote
  #72  
Old 02-27-2012
Member
 
Join Date: Apr 2011
Location: apopka, fl
Posts: 173
im being dead serious. i dont know when my gov. kicks in becuase i dont have a rpm gauge but it wasnt bouncing back an forth like it does when i rev it to the rev line.... but theres been no problems with my trucks motor ever. and i did 132 twice a month
Reply With Quote
  #73  
Old 02-27-2012
mhs2013's Avatar
Member
 
Join Date: Jan 2012
Location: Arlington, Texas
Posts: 161
love the 4.0l
Reply With Quote
  #74  
Old 02-29-2012
Member
 
Join Date: Apr 2011
Location: apopka, fl
Posts: 173
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
08 ranger 4.0l engine upgrades? foxmotoryder 4.0L OHV & SOHC V6 Tech 4 10-17-2011 10:20 AM
looking for some engine upgrades yellow rhino 2.9L & 3.0L V6 Tech 10 07-07-2010 08:57 PM
upgrades for engine? sideswipe 4.0L OHV & SOHC V6 Tech 12 10-06-2008 09:03 PM
cheap flex upgrades and chevy spring swap?'s gumby Suspension Tech 29 09-05-2006 08:36 PM
Jusnes Factory Upgrades blackrainja08 Exterior Semi-Tech 14 09-05-2006 04:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:19 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.