HELP ME!! - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-18-2009
meangrean's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: the Colony
Posts: 158
HELP ME!!

So i was drivin home from work today and all of a sudden my truck a pretty sufficient loss of power and kind of sputtered a bit and almost sounded like a harley with my exhaust system. It cant be a misfire cause i just got all new plugs and wires and a coil pack. Any ideas??!
1998 2wd xlt 3.0L
Reply With Quote
  #2  
Old 07-18-2009
bikerboy's Avatar
Member
 
Join Date: Sep 2008
Location: Lancaster, PA
Posts: 3
Check engine light come on? maybe an exhaust leak? if you started to hear the exhaust more...
Reply With Quote
  #3  
Old 07-18-2009
meangrean's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: the Colony
Posts: 158
no check engine light. It didnt really get louder it was just like a grumble.
Reply With Quote
  #4  
Old 07-18-2009
chainfire's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2007
Location: Mission B.C.
Posts: 3,126
Time to take it to a shop....
Reply With Quote
  #5  
Old 07-18-2009
meangrean's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: the Colony
Posts: 158
ya. i work at a ford dealer so it will be easy to do that. im just trying to get an idea...:/
Reply With Quote
  #6  
Old 07-18-2009
dangelj316's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2006
Location: Yuma, AZ
Posts: 813
Recheck all your plugs, wires, and coil pack. If you can find anything, then time to pay a shop!!
Reply With Quote
  #7  
Old 07-18-2009
meangrean's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: the Colony
Posts: 158
Ya. Well the check engine light just came on so im thinkin its an exhaust leak now. Never had to repair one can they get expensive?
Reply With Quote
  #8  
Old 07-19-2009
bikerboy's Avatar
Member
 
Join Date: Sep 2008
Location: Lancaster, PA
Posts: 3
It could be many things. go to your local autozone and get the codes pulled. post them up on here and then we can diagnose it correctly instead of taking shots in the dark.
Reply With Quote
  #9  
Old 07-19-2009
4x4RangerOffroad's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: Barrington, NH
Posts: 434
Ik most codes from repition of seeing them, so post it up and we'll figure it out.
Reply With Quote
  #10  
Old 07-19-2009
OVERtheEDGE's Avatar
Member
 
Join Date: Mar 2008
Location: locust grove georgia
Posts: 1,441
im thinking your plug wires got a loose connection or possibly got too close to the motor and melted. i see it happens all the time so thats a random guess.
Reply With Quote
  #11  
Old 07-19-2009
meangrean's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: the Colony
Posts: 158
hmm maybe. Im gonna go back to the mechanic and make him check it out. hopefully its something simple
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HELP !HELP! HELP! 3.0 V6 Driving me insane Hunter74 2.9L & 3.0L V6 Tech 21 03-06-2016 12:08 PM
Help Help Help!!!!!!! EdgeGOBoom 2.9L & 3.0L V6 Tech 6 09-16-2007 01:01 AM
Help Help Help Gear Indicator Stuck BananaEdge General Technical & Electrical 5 06-16-2005 12:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:18 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.