Two kinda random codes - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-17-2009
korey89's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: South, FL
Posts: 4,672
Two kinda random codes

Once in a while my CEL will come on and I get the same two codes. It first happened right after I got my scangauge a few times and then stopped for a while. Now I've had it come on the past two days in the morning. These are the two I get

P1000 OBD-II Monitor Testing Incomplete
P1121 Throttle Position Sensor Inconsistent with Mass Air Flow Sensor

Any ideas?
Reply With Quote
  #2  
Old 07-18-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Not being familiar with a scangauge , is there a setting in the unit that automaticly erases the codes after reading them ? That would account for the P1000.
P1121 the TPS has either got a dead spot in it or the MAF sensor is dirty , or the connectors to either may be loose/dirty.
Reply With Quote
  #3  
Old 07-18-2009
korey89's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: South, FL
Posts: 4,672
It doesn't automatically clear them, the CEL comes on, I read the codes, and then I press a button and it clears them and turns off the CEL.

But thanks for the help, I'll clean my MAF again and check the connectors.
Reply With Quote
  #4  
Old 07-20-2009
Prerunner-Ranger's Avatar
Level I Supporter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Any luck? Change the TPS for a new one, or get a new MAF.

My MAF is under lifetime warranty or some crap so I take it in every few months and get a new one.
Reply With Quote
  #5  
Old 07-20-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
I'd get things tested before you start throwing money on parts you don't need. Voltmeter and some time is all you need.
Reply With Quote
  #6  
Old 07-20-2009
korey89's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Mar 2008
Location: South, FL
Posts: 4,672
I cleaned the MAF again, but the CEL is so random so IDK if it did anything. I'm gonna test my TPS if it stops raining here.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
FX4 Level 2 Two Tone Color Schemes & 93+ Two Tone Rangers Hillyard Exterior Semi-Tech 1 03-11-2015 09:04 AM
Codes and Codes fraser19 General Ford Ranger Discussion 0 06-14-2013 03:14 PM
CODES CODES- IDLE issue supraboatguy General Technical & Electrical 1 11-08-2011 02:17 AM
Two months two late! dixie_boysles Wheels & Tires Semi-Tech 19 02-15-2010 04:13 PM
Two tone, or not two tone... Sixt9coug Exterior Semi-Tech 20 12-13-2009 07:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:39 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.