Idle speed and IAC ? - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-25-2007
Member
Thread Starter
 
Join Date: Mar 2007
Location: texas
Posts: 16
Idle speed and IAC ?

Well since I bought my 2001 Mazda B3000 3.0L I have noticed that when I start the truck it shakes and the idle bounces. Not really bad, maybe up and down 200rpms but it is there and annoying. Also it only does this while cold. I have cleaned the IAC, put a custom CAI with a K&N on, cleaned Tb, and seafoamed it. My truck only has 35,000miles on it so it should not need a tune up.
Also if yall could tell me what these 3.0L's idle at? Mine is 1200 at cold and 900-1000 warm. Thanks!
Reply With Quote
  #2  
Old 06-25-2007
sem1845's Avatar
Member
 
Join Date: Jun 2004
Location: Prattville, AL
Posts: 265
that sounds about normal... my iac was bad and when i cranked up it would rev to 3k rpms!!!!
Reply With Quote
  #3  
Old 06-25-2007
Member
Thread Starter
 
Join Date: Mar 2007
Location: texas
Posts: 16
wow!!
so what about the rough idle, does this sound about normal too?
Reply With Quote
  #4  
Old 06-25-2007
sem1845's Avatar
Member
 
Join Date: Jun 2004
Location: Prattville, AL
Posts: 265
now that i've got a new iac it idles fine... it has always idled up and down a little right around 1k rpms
Reply With Quote
  #5  
Old 06-25-2007
Level I Supporter
 
Join Date: Aug 2006
Location: Durham, NC
Posts: 3,657
Clean the MAF sensor, and reinstall the OEM intake, filter box, and OEM paper filter.

This will fix your rough idle problems......The ONLY thing you gained with the CAI and K&N is more noise, and more dirt into your engine.
Reply With Quote
  #6  
Old 06-25-2007
Member
Thread Starter
 
Join Date: Mar 2007
Location: texas
Posts: 16
Oh ya I forgot to say I have cleaned the MAF 3 times. And the reason I put the CAI and K&N in is because of this problem. This happened before when it was stock.
Also to make it more clear I still have the box I just put 3in. tubing from the box to the wheelwell and 3in tubing from the box to tb. Also snorkel is out.
Reply With Quote
  #7  
Old 06-25-2007
Member
Thread Starter
 
Join Date: Mar 2007
Location: texas
Posts: 16
Do you think the autoparts store would allow me to install a new IAC and return it later if it does not fix it?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How to: Clean IAC (Idle Air Control Valve) 99offroadrngr How-To & DIY Submissions 0 05-09-2014 06:16 PM
Cleaned IAC and throttle, now high idle? Clinton 4.0L OHV & SOHC V6 Tech 17 05-12-2011 11:55 AM
New Idle Air Control (IAC) Valve Issues Liquidswords32 General Technical & Electrical 0 05-11-2011 01:33 PM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 12:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:09 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.