loosing water every couple of days - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-28-2012
Member
Thread Starter
 
Join Date: Dec 2012
Location: columbus, georgia
Posts: 6
loosing water every couple of days

2000 Ranger 3.0 loosing water about 3/4 gal every 3 days, no leaks in driveway, t-stat works, over flow bottle full, runes smooth some water at tail pipe, not coolant but its cold here may be condensation.bad cap ? faulty water pump leaking while driving ? lost here
Reply With Quote
  #2  
Old 12-28-2012
PAShooter's Avatar
Member
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Possibly head gasket, i went through 3 on my 3.0. smell the exhaust and see if it smells sweet and if it blows smoke.
Reply With Quote
  #3  
Old 12-28-2012
Member
Thread Starter
 
Join Date: Dec 2012
Location: columbus, georgia
Posts: 6
no smoke or sweet smell, I think the water is getting past the cap, over flow box is full and water warm
Reply With Quote
  #4  
Old 12-28-2012
Member
Thread Starter
 
Join Date: Dec 2012
Location: columbus, georgia
Posts: 6
hope its a bad cap, it is the original one ! no sweet smell or any smoke
Reply With Quote
  #5  
Old 12-28-2012
FULLSCALE's Avatar
Level III Supporter

iTrader: (12)
 
Join Date: Mar 2009
Location: Clinton, Ontario
Posts: 8,181
At least the cap is an easy and inexpensive part to try... let us know how it goes!
Reply With Quote
  #6  
Old 12-28-2012
Member
Thread Starter
 
Join Date: Dec 2012
Location: columbus, georgia
Posts: 6
I sure will, the water has to go some place, its not on the ground, no obvious leaks no smoke or anti freeze at the tail pipe but lots of water in the overflow container and its warm

new T-stat seems to do the trick, will wait and see

Last edited by shadow; 12-29-2012 at 05:22 PM. Reason: adding ino
Reply With Quote
  #7  
Old 12-29-2012
Member
Thread Starter
 
Join Date: Dec 2012
Location: columbus, georgia
Posts: 6
I changed the cap, still had a prob replaced the t-stat which was rusted and falling apart, water level stays full and no more filling of the over flow bottle ya ya ya
Reply With Quote
  #8  
Old 12-29-2012
Member
Thread Starter
 
Join Date: Dec 2012
Location: columbus, georgia
Posts: 6
not sure were to leave the reply
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
what ive been up to the past couple of days rstangboi Audio & Video Tech 21 06-27-2008 08:44 AM
man, LONG last couple of days with the truck RangerBoy02FX4 General Ford Ranger Discussion 6 08-02-2006 09:49 PM
loosing my t-bar crank.... INT3RC3PTOR Suspension Tech 10 01-21-2006 10:55 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:58 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.