MAS question - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-06-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
MAS question

when your MAS is bad it won't get the right air to fuel ration right? and that could cause it to accelerate poor, idle wrong, and sometimes buck around right? just making sure that thats the issue not something else
Reply With Quote
  #2  
Old 05-13-2011
Member
 
Join Date: May 2011
Location: Piney Creek, NC
Posts: 8
Have you tried cleaning the MAS? I've heard of issues with the oiled filters causing problems with the MAS.
Reply With Quote
  #3  
Old 05-13-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
yeah i cleaned still threw a code and acted up and i put the stock intake back in it still had the problem with it cleaned, so i got a nice new re manufactured one for auto zone with a nice 10% discount :D for having to drive 30 miles out of my way cause no were closer had the part in stock, no bucks, kicks, randomly stop accelerating, no codes, and good idle. man gotta love MAS, even though some of it was contributed to the o2 sensors being bad too
Reply With Quote
  #4  
Old 05-13-2011
Member
 
Join Date: May 2011
Location: Piney Creek, NC
Posts: 8
Good to hear its solved, in your case maybe not the oiled filter after all?
Reply With Quote
  #5  
Old 05-14-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
yeah idk if that was it or not it ran good the first day i had it one, it probably a coincidence, but idk now if i want to take a chance, with the intake that i want to put on,i mean when other people do cold air intakes do they have to do anything or does it use the stock mas
Reply With Quote
  #6  
Old 05-14-2011
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
Quote:
Originally Posted by 894banger View Post
i mean when other people do cold air intakes do they have to do anything or does it use the stock mas
you reuse your factory MAF sensor...i havent had a problem(knock wood lol)
Reply With Quote
  #7  
Old 05-14-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
haha, thats what i though, i just don't want this one to get damaged, too expensive for that
Reply With Quote
  #8  
Old 05-15-2011
Member
 
Join Date: May 2011
Location: Piney Creek, NC
Posts: 8
My experience was on a used F-150. Had a K&N filter on it when I bought it but stock intake from the filter itself to manifold. Had some minor problems that went away after cleaning then switched back to paper filter. Read several threads on F-150 Forums that mentioned the oiled filters as possible problems.
Reply With Quote
  #9  
Old 05-15-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
yeha and i heard that on hear, but hen again a lot of people on hear have them in their trucks
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help needed: MAS Swap camokid 2.9L & 3.0L V6 Tech 56 07-23-2009 12:27 PM
ANOTHER Early X-Mas Gift Rolldogg Snapshots 27 12-26-2008 10:11 PM
Error Codes/MAS issue? Ringfinger 4.0L OHV & SOHC V6 Tech 0 12-09-2008 11:11 AM
X-mas 1999Rangerlockednlifted New Ideas 8 12-06-2008 08:22 PM
New Mod :) X-MAS GIFT Line of Fire! WholesaleMN.com General Ford Ranger Discussion 14 12-22-2004 06:29 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:03 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.