Need Serious Help - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-18-2008
Member
Thread Starter
 
Join Date: Mar 2008
Location: grover beach, ca
Posts: 19
Need Serious Help

--------------------------------------------------------------------------------

Hey Guys I Have A Problem With My Ranger... So The Smog Is Due And My Check Engine Light Is On... I Took It In And It Failed Of Course So They Said That The Code Said That My Truck Had Some Sort Of Lean, Which Is Supposely Related To The Motor Not Pulling Sufficient Gas... So Then I Thought That Maybe By Getting A Tune Up It Would Fix It But It Didnt... And To Make Things Worse When I Turn My Truck On And Leave It Just Running For A Lil Bit, I Start Feeling The Truck Like Shaking.. It Is Some Kind Of Rocking Motion From Side To Side Not Severe But I Am Able To Notice It... So Can Somebody Help Me By Telling Me If This Has Ever Happen To One Of You Guys And What Exactly Did You Have To Do To Fix It... Im Seriously Worried Just Since My Ranger Its My Only Car And I Use It For Everyday Things... Any Help Is Very Appreciated Thanksss...
Reply With Quote
  #2  
Old 12-18-2008
Rapala's Avatar
Member
 
Join Date: Jun 2008
Location: North Carolina
Posts: 826
Mind describing the smog??? like what color what it smells like?


but this does sound like my families expedition with the 4.6 it has a bad PCV valve it will smoke like a mother..... since we replaced the valve no more smoke.. but that was white and almost smelled like burning oil
Reply With Quote
  #3  
Old 12-18-2008
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
The code was for the cylinder running lean. Have you checked both 02 sensors, spark plugs, clean the IAC, etc? All that will be free to check/almost free to clean.
Reply With Quote
  #4  
Old 12-18-2008
bwester04's Avatar
Member
 
Join Date: Mar 2006
Location: Round Rock, Tx
Posts: 2,641
*having trouble reading through all of the first letters being capitalized..* whoa my eyes lol jk

However I agree with Trent, o2 sensor(s) issue is what it sounds like..

"let me see your ranger lean.." lol
Reply With Quote
  #5  
Old 12-20-2008
Alie's Avatar
Member
 
Join Date: Nov 2008
Location: NJ
Posts: 31
Lean means- you're not getting enough fuel or too much air!

First I'd check the codes again, which 02 sensors are reading LEAN???

go to autozone and ask for a free scan the plug is under driver side dash...then tell us what the codes are.

If both sensors in bank 1 and bank 2 are reading lean, chances are it isn't the sensors that are screwed....i'd go check the mass air flow sensor first and see if that baby is working right.
Reply With Quote
  #6  
Old 12-20-2008
Jp7's Avatar
Jp7 Jp7 is offline
Member
iTrader: (9)
 
Join Date: Sep 2007
Location: My LED lab or on the dyno
Posts: 2,970
I have MAF sensors for sale for the newer 3.0 rangers if you need one.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
NEED SERIOUS HELP ASAP. immortal_vision Drivetrain Tech 0 02-09-2011 03:33 PM
Serious Problem, need Help ASAP!!!!!! God,Country,FORD Suspension Tech 23 03-06-2009 12:36 AM
Need Serious Help( Motor) 805cali Member Introductions 11 12-21-2008 12:55 AM
Need Serious HELP!!!!!! 94greenmachine Drivetrain Tech 14 12-26-2007 08:26 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:35 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.