Rough Idle - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-11-2008
jrpro130's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
Rough Idle

Now I'm not usually one to post up for mechanical help, but I'm a little stumped...

I'm having a rough idle. It is amplified with the AC on, obviously. Truck runs great above 1500rpms. I did the seafoam treatment 2 times yesterday without any change. I checked for vacum leaks by spraying brake cleaner on all vacuum lines. Problem is...I have NO idea where my PCV valve is...I know it needs to be replaced, it's origional and I'm at 93k miles.

I did plugs about a year and a half ago, but I'm going out to do them now. I unplugged the IAC and it idled down, so I know that works. I just cleaned the MAF about a month ago, but when I unplug it, it doesn't do much, when I plug it back in, it stumbles for a second then goes back fine. I just did my fuel filter a few weeks ago too...I have fresh gas in the tank.

I am thinking coil pack? I just don't know because it runs good at 1500rpms and up, and no decrease in MPG????

I'm stumped.
Reply With Quote
  #2  
Old 10-11-2008
mj550's Avatar
Member
 
Join Date: Apr 2006
Location: USA
Posts: 601
Did you clean the idle speed motor or whatever its called in the throttle body?
Reply With Quote
  #3  
Old 10-11-2008
jrpro130's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
Yes, i cleaned it.

Well so far so good...I replaced all the spark plugs, they were pretty disguisting. They all had gunk and stuff on them. I replaced them about a year and a half ago, but didn't put two and two together. So, so far so good. We'll see how the day goes, I ran it for about 10 mins and it was really smooth.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE ChargerOnDavins 2.9L & 3.0L V6 Tech 3 03-23-2015 04:25 PM
1995 rough idle/slow return to idle whiskeybreath SOHC - 2.3L & 2.5L Lima Engines 1 11-27-2014 05:06 PM
M5OD rough shift on rough roads, potholes, speed bumps Mike_92 Drivetrain Tech 0 10-28-2013 10:26 PM
1997 Mazda b2300 starting rough, running rough! bonecrusher SOHC - 2.3L & 2.5L Lima Engines 3 03-19-2011 05:04 AM
Rough idle, check engine light SnowGoAK 4.0L OHV & SOHC V6 Tech 6 06-24-2005 04:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:58 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.