Somebody please help me out!.... - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-31-2016
Member
Thread Starter
 
Join Date: Mar 2015
Location: Missouri
Posts: 11
Somebody please help me out!....

I got a 1994 Ford Ranger 3.0 V6 manual 5 speed 4x4 with 231,000 miles. I bought it about a year ago and CAN NOT fix this rough idle and misfire issue. I have done a complete tune up on it, new plugs, wires, distributor cap, rotor, IAC valve, MAF, New injectors, intake gaskets, ignition coil, TPS, Checked vacuum lines, compression test, everything I can think of. I have spent hours reading the 3.0 rough idle stories. When I first start it up, it runs and sounds good for a few minutes until idle comes down to about 750 and its rough. Also, going down the highway is fine, until it's in OD lugging up a hill or around 2000 rpm it misses and bucks every 5 seconds or so. Any ideas?
Reply With Quote
  #2  
Old 03-31-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,615
I assume there is a new TFI module since every thing else was replaced?
They become heat sensitive, i.e. work fine when cold then start to cause issues when warmed up.

Check distributor shaft, I had a bad bushing in a distributor one time and it was a PITA to diagnose, pull off cap and check play in rotor, have someone crank engine with cap off to see if shaft is spinning true, and do it after engine is warmed up.
Cold bushing was fine, once it was spun around a bit I got the wobble.


If you have an EGR system issue it can also show all of the symptoms described, rough idle after warm up, and loss of power/cutting out if EGR valve opens too much.
Reply With Quote
  #3  
Old 03-31-2016
Member
Thread Starter
 
Join Date: Mar 2015
Location: Missouri
Posts: 11
Thanks RonD, I also thought about the distributor shaft, and I will check the play in it tonight. Mine does not have the EGR system. I also thought about a bad ground? But it starts right up, barely cranks and it starts right up so I ruled that out.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Can somebody please answer my question? J Hawks8 4.0L OHV & SOHC V6 Tech 6 06-13-2009 05:38 PM
I need help from somebody with access to a 2004 (2005?) Ranger. winks General Technical & Electrical 20 08-07-2008 08:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:57 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.