spark knock/detonation issue. PLEASE HELP!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-31-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
spark knock/detonation issue. PLEASE HELP!!!

So i bought a 2000 3.0 a month and a half ago, and about two weeks after i got it, it started a nasty spark knock. I've changed the plugs and wires ( which were original, 79,000 miles), changed the oil and filter, pcv, air filter, egr sensor (irrelevant i believe) ran gunk out through the gas, ran seafoam through the brake booster vacuum line, cleaned the wires on the maf, and its still doing it. I did the plugs and wires, and cleaned the maf at the same time, and it stopped for a little over a week, but now its back. Any help is much appreciated.
Reply With Quote
  #2  
Old 07-31-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
try running seafoam through again.
Reply With Quote
  #3  
Old 07-31-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
i just did that today. is it ok to do it again so soon?
Reply With Quote
  #4  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
bump
Reply With Quote
  #5  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
anybody?
Reply With Quote
  #6  
Old 08-02-2010
StrangerRanger's Avatar
Member
 
Join Date: Jan 2009
Location: The 253
Posts: 756
I've just suffered with mine and learned to rev it out a bit when climbing a hill. Easier to do with a stick but it seems to work for me. I have yet to find the way to make it stop. I think the problem is the fact that its a 3.0.
Reply With Quote
  #7  
Old 08-02-2010
03crewcabranger's Avatar
Member
 
Join Date: Feb 2010
Location: Mty, Mx
Posts: 1,031
Have you tried a better gas?
Reply With Quote
  #8  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
lol yeah i tried reving it out, doesnt help much, and yes, i bumped up to 89 instead of 87 on saturday, and still no change. i really wish i would have gotten a 4.0.
Reply With Quote
  #9  
Old 08-02-2010
03crewcabranger's Avatar
Member
 
Join Date: Feb 2010
Location: Mty, Mx
Posts: 1,031
How much old gas did you gas tank still had when you refilled it with 89? Mine knocked for a week after a switched to a better gas and then it stopped.
Reply With Quote
  #10  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
i was pretty close to empty, and i put a half tank in of 89. i think i may try to sea foam it again today on my lunch break.
Reply With Quote
  #11  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
was your also puffin out smoke, while it knocked?
Reply With Quote
  #12  
Old 08-02-2010
03crewcabranger's Avatar
Member
 
Join Date: Feb 2010
Location: Mty, Mx
Posts: 1,031
Not at all...
Reply With Quote
  #13  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
well mines puffing out smoke along with the knock, the smoke is usually a bluish grey, which im told is unburned fuel, and once in a while, a puff of black smoke. any ideas? Thanks for the input so far btw. much appreciated.
Reply With Quote
  #14  
Old 08-02-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Get the codes pulled and post them here.
Reply With Quote
  #15  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
will it throw codes without the check engine light on?
Reply With Quote
  #16  
Old 08-02-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Quote:
Originally Posted by Dossey View Post
will it throw codes without the check engine light on?
Yes
Reply With Quote
  #17  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
ok, ill have them posted in about an an hour.
Reply With Quote
  #18  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
went up to autozone after work, put a obd2 on it but it didnt show any codes. how do i get codes?
Reply With Quote
  #19  
Old 08-02-2010
Member
 
Join Date: May 2010
Location: dayton
Posts: 67
if the check engine light is on than you should have codes. instigate the condition again and get the light to stay on before you get it checked out.

Either that or your fuse is burned out..in which case the obd2 tool wouldn't power on.
Reply With Quote
  #20  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
lol no, there is no check light coming on at all. and the fuse is fine.
Reply With Quote
  #21  
Old 08-02-2010
Member
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
Put a can of seafoam in the tank.Also buy a can of seafoam deepcreep and remve intake tube at throttle body and squirt the throttle body down following directions on the can.should have good results by the time you run thru the gas.does same thing as putting it thru the hose but take a little longer and is probably a little safer for your engine doing it this way.
Reply With Quote
  #22  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
Quote:
Originally Posted by BigEdge126 View Post
Put a can of seafoam in the tank.Also buy a can of seafoam deepcreep and remve intake tube at throttle body and squirt the throttle body down following directions on the can.should have good results by the time you run thru the gas.does same thing as putting it thru the hose but take a little longer and is probably a little safer for your engine doing it this way.
Thanks, i ran 2/3 of the bottle through on my lunch break this afternoon, through the vacuum hose again, didnt seem to help, but i just went for a drive for about an hour, and i didnt notice it once. so as of now its fixed. either the seafoam or the 87 finally ran out and now just 89 is goin through.
Reply With Quote
  #23  
Old 08-02-2010
StrangerRanger's Avatar
Member
 
Join Date: Jan 2009
Location: The 253
Posts: 756
If its smoking that's something else... Like water in the tank bad gas kinda stuff. Or bad o2 sensors..
Reply With Quote
  #24  
Old 08-02-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
Quote:
Originally Posted by StrangerRanger View Post
If its smoking that's something else... Like water in the tank bad gas kinda stuff. Or bad o2 sensors..
i was told that the smoke was from the combustion being messed up, but the o2s are original, and probably should be changed regardless.
Reply With Quote
  #25  
Old 08-03-2010
Dossey's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: belleville, mi
Posts: 73
nvm on it being fixed, it happened almost all the way to work this morning. Any one wanna trade me for a 4.0?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
miss, lean codes, and detonation Please Help!! daranger101 2.9L & 3.0L V6 Tech 0 02-05-2012 03:11 PM
Detonation....a little help please bergs 4.0L OHV & SOHC V6 Tech 9 12-16-2009 10:59 AM
Knock knock, Please help Jack Man 2.9L & 3.0L V6 Tech 3 08-12-2009 09:14 PM
Help with Spark Knock Please!! vansnxtweek 4.0L OHV & SOHC V6 Tech 7 03-12-2008 10:33 AM
knock knock goes the engine. cdn2x4ranger 2.9L & 3.0L V6 Tech 3 11-04-2007 01:03 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:30 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.